Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
rebeccaelder
New Member

How to keep slicer visible?

I have built a dashboard with several pages that are set up the same way. On one of them, the year filter/slicer disappears when you click on the pie chart that the slicer is connected to. I have tried sending the pie chart to the back and the slicer to the front, but it still happens. I built the other slicers/pie charts the same way and it does not happen with the others.

 

Any ideas for how I can get the slicer to stay visible while the pie chart is selected?

 

For reference, the problem is on page five of the Power BI project on this page: https://www.como.gov/sustainability/

This is how the page is supposed to look, and how it works before clicking on a slice of the pie.This is how the page is supposed to look, and how it works before clicking on a slice of the pie.Once selecting a section of the pie chart, the year filter disappears.Once selecting a section of the pie chart, the year filter disappears.

1 ACCEPTED SOLUTION
rebeccaelder
New Member

I did figure out how to fix it- I shrunk the pie charts so that the edge of the filer is just barely to the right of the pie chart. I don't know why bringing the filter forward didn't work. I have used this project for a couple of years, and I think this issue just popped up and I'm not sure why. But for now this is working!

View solution in original post

5 REPLIES 5
rebeccaelder
New Member

I did figure out how to fix it- I shrunk the pie charts so that the edge of the filer is just barely to the right of the pie chart. I don't know why bringing the filter forward didn't work. I have used this project for a couple of years, and I think this issue just popped up and I'm not sure why. But for now this is working!

thomazinh
Helper I
Helper I

Try the following: 

(A) You can turn off the background on your pie chart under Format>General>Effects>Background. This way it'll be transparent and the slicer will always show. 

(B) Ensure the layer order of the slicer is above the pie chart

Turning the background off does keep the slicer visible, but then it won't let me select a different year after I have selected the pie chart. Is it worth trying to completely rebuilt the page?

DOLEARY85
Super User
Super User

Hi,

 

Check the format ribbon, click on the slicer and then bring the slicer to the front:

 

DOLEARY85_0-1683038809842.png

 

If I answered your question, please mark my post as solution, Appreciate your Kudos 👍

Thanks for your answer-I had tried that prior to posting this, and for some reason that is not working on this particular page.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.