Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
mcmum01
Helper I
Helper I

Encryption Error when Connecting to Impala

A couple of weeks ago I was able to connect to Impala through Power BI. Recently, I have been getting an error stating:

 

mcmum01_0-1609262720199.png

 

Like many other posts have suggested, I unchecked the "Encrypt connections" box:

 

mcmum01_1-1609262772016.png

 

I have deleted credentials, re-added them, cleared permissions and re-added, but I am still getting that pesky error. I have tried to some searching of other posts and they have all suggested to uncheck the box. That is not working.

 

Any ideas? I feel like I am at a loss right now.

 

6 REPLIES 6
v-jingzhang
Community Support
Community Support

Hi @mcmum01 

 

Have you tried clicking OK on the Encryption Support dialogue? It is a confirmation message that confirms with you to use an unencrypted connection. Click OK and it will continue to connect to the data source. Have a try!

 

Kindly let me know if this helps.

Community Support Team _ Jing Zhang
If this post helps, please consider Accept it as the solution to help other members find it.

I did do that. The second screenshot shows the "Encryption Connections" box unchecked.

What is the behavior after that? Is there any error message?

I get the same "encryption support" error when I refresh the data.

amitchandak
Super User
Super User

I did log the issue there and someone pointed me to a post that wasn't relevant. Here is my post:

 

https://community.powerbi.com/t5/Issues/Encryption-Error-when-Connecting-to-Impala/idi-p/1573853#com...

 

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.