Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
vincentnoot
Resolver I
Resolver I

Data refresh crashes and immediately disappears

Hi,

 

My data refresh encounters an error, but the window disappears immediately afterwards, so it's impossible to troubleshoot the queries.

Also, refreshing each table individually results in no error for any of the tables, it only crashes when using the refresh button in the ribbon.

8 REPLIES 8
aaraneo
New Member

I am experiencing this on several PBIX files. Rolling back to May 2022 update did the trick. Not sure if any of the versions between that and the latest work fine. You can find previous desktop versions here:

https://learn.microsoft.com/en-us/power-bi/fundamentals/desktop-latest-update-archive?tabs=powerbi-d...

 

but once you have opened the dashboard in new version it doesnt open in old version anymore.

 

MeghanDeWet
Frequent Visitor

Can you let us know if you find a solution? I am having the same issue.

I can refresh tables individually but I have quite a few, so it can be very time consuming.

Anonymous
Not applicable

Hi vincentnoot 

 

I am having the same problem. Has it solved for you?

 

Thanks

 

Jing

@vincentnoot @Anonymous I have same issue recently and finally found the root cause by spending lots of time.

 

My issue was I deleted an uneccessary table and raw data files but still reference M query to make a function (fx) was existing.

Once I deleted it, everything has been fine.

 

Guessing the function referred to the sample file parameter to load the data, however the file couldn't be found cause an error. And then Power BI should show an error but the frontend table has also already gone that made unable to show a proper error message.

 

If your issue is different with me, guessing it may related with relationship between active and deleted table/column, because I tested by disabling data refresh to all the tables but still same symptom occurred, thus active table would not be a root cause.

 

I believe this is a Power BI desktop bug as I didn't experience this issue before, anyways...

May the force be with you.

Hi,

 

I haven't really solved it. I manually refreshed all tables and uploaded it to the Power BI Service. It now seems to refresh fine in there, so I'll just try not to touch it until this gets solved.

vincentnoot
Resolver I
Resolver I

To supply some more information: 

  • Other dashboards using the same data sources run without any issues. 
  • Older versions (that worked fine in the past) of the dashboard have the same issue
  • Clearing all source permissions doesn't work
  • Clearing all caches doesn't work
  • The dashboard also won't refresh in the Power BI service

 

Any ideas for how to trouble-shoot or solve this issue?

Anonymous
Not applicable

Mine is solved too. I found colume names of one of my data source were altered. @Sashimi is probabally correct about it's a bug.

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.