Showing results for 
Search instead for 
Did you mean: 

Fabric is Generally Available. Browse Fabric Presentations. Work towards your Fabric certification with the Cloud Skills Challenge.

Helper II
Helper II

Can't select Column in the Value field of a chart, only measurements



EDIT2: I think I probably need to rephrase the question. The problem is in the "Verbruik [totaal]" not being seen as a Numeric Value. But I can't seem to change it to Numeric. It's set as a Decimal number in all possible ways, but Power BI won't see it as a Numeric....



I think I'm going crazy at the moment..

I can't select a column to show up in a chart (bar chart, stacked column charts, doesnt matter which one). I can't drag it to the Values field of the chart. I can only select a Measurement


The column is set as decimal number.


Since I've downloaded the new version this has become an issue.


Can someone help?



It does work on a new Power BI with the same source.... 

But also in that version I was able to make the "Verbruik [totaal]" a numeric value. Which I can't seem to manage in my previous Power BI 






Not applicable

Hi @TaraB89,

I had the same problem and found the solution here in a community post. (I don't remember who the person was anymore, so I apologize for the lack of citation), but the problem may be related to the Tabular Editor. In the model, you have to disable the option "Discourage Implicit Masures".


Frequent Visitor

Same is happening to me after PBI upgrade. Connected to db, column is set to float & PBI recognizes that as number. Summarzies it in matrix, but doesnot allow to add in 'view' box in a chart visual. This is driving me crazy.

Helper I
Helper I

I have encountered the same error after updating to Feb 2021 version of PBI Desktop. What is interesting, in my case it is report related. In some reports I can drag numeric fields to values without problems, in others numeric fields behave as text fields. 

Galapaka in this thread
has discovered that the issue is most likely caused by discourageImplicitMeasures setting in the model. 

For me there was a real connection with the mod Tabular Editor. I started using Tabular Editor in Q3-2020 and after that the reports had this issue.

The same report but the version of Q2-2020 had no issue. 

In the end I never found a solution and had to rebuild all the changes I made starting from the Q2-2020 report.

Helper II
Helper II

help power bi.JPG


I tried a pie chart aswell but I cant drag it. I can select the column but it wont let me put it in Value then.


On old charts its still ok, I just can't seem to make new ones....

See the picture below which shows the "old graph" (made before the version switch) where the same column is used as a value.


help power bi 2.JPG



I can't share the pbix file, i'll see if I can reproduce this in a new pbix


the calculation in the column is a substraction first, and then a conversion. 


kind regards,


Hi @TaraB89 ,

Could you please confirm whether the data type of field [Verbruik(kWh)] is numeric type? And as checked your screenshot, it seems you were trying to create a pie chart visual in new file. Please try to drag the field [Verbruik(kWh)] to Values option.

Can't select Column in the Value field of a chart, only measurements.JPG

Best Regards
Community Support Team _ Rena Ruan
If this post helps, then please consider Accept it as the solution to help the other members find it more.

Community Support Team _ Rena
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.


I can't put any Column in Values. I can try to drag but the moment I release the selected field above "Values", nothing happends. 

I have an old version (few months back...) where it does work. And the difference is that "Verbruik [totaal]" has the Numeric icon in front of it. "Verbruik [kWh]" comes from that one.


Unfortunately, its not just "Verbruik [kWh]" that is the problem. I cannot move ANY column into the values field. Only measurements. 

In the screenshots below you see the settings of Verbruik kwh and Verbruik totaal.

And once more Verbruik totaal in the Query editor where you can see it's a decimal number and should have a Numeric icon in front of it.

help power bi 3.JPGhelp power bi 4.JPG

help power bi 5.JPG


I'm afraid that the file is corrupted in some way, since new Power BI's and even an older version do work.

But I would really really love to uncorrupt this or I have to do a lot of stuff again .... 😞 



Super User
Super User

@TaraB89 , I tried draging a column on the pie visual in values column. I am able drag date/text and number all column and it has taken correct aggregation. I have not see any issue reported like this in last few days.


Can you share screenshot or pbix file

Helpful resources

PBI November 2023 Update Carousel

Power BI Monthly Update - November 2023

Check out the November 2023 Power BI update to learn about new features.

Community News

Fabric Community News unified experience

Read the latest Fabric Community announcements, including updates on Power BI, Synapse, Data Factory and Data Activator.

Power BI Fabric Summit Carousel

The largest Power BI and Fabric virtual conference

130+ sessions, 130+ speakers, Product managers, MVPs, and experts. All about Power BI and Fabric. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors