Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Element115
Power Participant
Power Participant

Background color rules for table cells not working

Desktop vs July 2022

 

Brief description:  Cell elements background color does not cut off color at the right boundary when using percentages, which are specificied in the settings as whole numbers > 0 and not decimals between 0 and 1. If using decimal values instead, it works even less.  

 

The 3 screenshots are self-explanatory and you will see immediately the nature of the problem.

 

formatting_Screenshot 2022-08-05 222009.png

 

cell_element_bg_settings_Screenshot 2022-08-05 222101.png

 

wrong_cutoff_Screenshot 2022-08-05 222031.png

 

2 ACCEPTED SOLUTIONS
vanessafvg
Super User
Super User

you need to use 0.50 as an example  for percentages I think. ie 50% is 0.50 have you tried that?





If I took the time to answer your question and I came up with a solution, please mark my post as a solution and /or give kudos freely for the effort 🙂 Thank you!

Proud to be a Super User!




View solution in original post

Kaly
Resolver II
Resolver II

Hi  @Element115 ,

According to the snapshot, you select Percent in the dropdown, the Percent in this place does not mean percentage as in the datatype option.  It means you’re setting the rule boundaries as a percent of the overall range of values from minimum to maximum.

Kaly_0-1660209234238.png

For example in the below sample, the 0 Percent means the minmum value -50%, the 50 Percent should be (50%+(-50%))/2=0, so the backgroud color of value from -50% to 0 get red, it's correct.

Kaly_1-1660209595620.png

Instead, if you want to get the correct number value, you should select Number in the dropdown like this:

Kaly_2-1660209873786.png

Kaly_3-1660209966839.png

Refer to this official document: Apply conditional table formatting in Power BI - Power BI | Microsoft Docs

 

Best Regards,

Kaly

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

View solution in original post

3 REPLIES 3
Kaly
Resolver II
Resolver II

Hi  @Element115 ,

According to the snapshot, you select Percent in the dropdown, the Percent in this place does not mean percentage as in the datatype option.  It means you’re setting the rule boundaries as a percent of the overall range of values from minimum to maximum.

Kaly_0-1660209234238.png

For example in the below sample, the 0 Percent means the minmum value -50%, the 50 Percent should be (50%+(-50%))/2=0, so the backgroud color of value from -50% to 0 get red, it's correct.

Kaly_1-1660209595620.png

Instead, if you want to get the correct number value, you should select Number in the dropdown like this:

Kaly_2-1660209873786.png

Kaly_3-1660209966839.png

Refer to this official document: Apply conditional table formatting in Power BI - Power BI | Microsoft Docs

 

Best Regards,

Kaly

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

vanessafvg
Super User
Super User

you need to use 0.50 as an example  for percentages I think. ie 50% is 0.50 have you tried that?





If I took the time to answer your question and I came up with a solution, please mark my post as a solution and /or give kudos freely for the effort 🙂 Thank you!

Proud to be a Super User!




Yes, but with Percent selected and that does not work. But you are right when Number is selected it works, as @Kaly suggested. Thanks everyone!

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.