SQL DataFlow via on-prem gateway preview works but does not refresh
I am trying to setup a dataflow that connects to an on-premise SQL database via the powerbi gateway. When congifuring the dataflow, the power query preview does bring through the data from the table which confirms that the gateway is working. When I save the dataflow and try to refresh the data, it fails with the following error:
Error: AzureBlobs failed to get the response: 'Unable to connect to the remote server'. Request ID: xxx
I have had the on-prem gateway version updated as suggested by a couple forums, but this has not made a difference. Also, the table that I am testing with only has a couple varchar columns to remove potential of datatype compatibility problems that I am aware of.
8 Comments
- v-robertq-msft
Community Support
Hi,
According to my research, a similar issue has been reported internally, so stay tuned. ICM: 259072545
Best Regards,
Community Support Team _Robert Qin
- AnonymousNot applicable
Hi there,
I got a similar problem - trying to connect to an IBM DB2 via Dataflow.
Gateway connection to Database ist established, I see preview Data but when I want to refresh I get an error message (different than the one jswift got):
Error: Program execution reached an invalid state. The execution should have never reached this code.
Has there been a solution yet v-robertq-msft ?
Best regards,
CP
- jswiftRegular Visitor
Update:
Microsoft is on the case with this one. we did progress this by allowing the azure endpoints on our proxy. the error I am now experiencing is:
Error: AzureDataLakeStorage failed to get the response: 'Unable to connect to the remote server'
I will post an update once resolved
- cmontoya88Frequent Visitor
Hi community,
I have a similar errors (the preview view show the data but refresh failed):
- Error: AzureBlobs failed to get the response: 'Unable to connect to the remote server'
- Error: AzureBlobs failed to get the response: 'The operation has timed out'
Please, any idea to solved that?
- RoxanaGRegular Visitor
Hi community,
I have the same error Error: AzureBlobs failed to get the response: 'Unable to connect to the remote server'
when I try refresh the data flows
any idea to solved?
Thanks and regards
- cmontoya88Frequent Visitor
Hi,
You have get the IP ranges of cloud microsoft (Download Azure IP Ranges and Service Tags – Public Cloud from Official Microsoft Download Center) to add this list to white list so that your Gateway Server communicate with cloud (your gateway server must have out to IP's). Choose your regions (view in the gateway software your region) and get the IP range to AzureCloud, AzureStorage, PowerBI, PowerPlatformInfra, PowerQueryOnline.
The problem is that the IP's are updated each week...
- jswiftRegular Visitor
Thank you cmontoyabb
The issue that we had was that the on-premise gateway was not able to use our proxy which has all the appropriate IP ranges allowed. A manual update to the config file was required as follows:
File location\name:C:\Program Files\On-premises data gateway\m\Microsoft.Mashup.Container.NetFX45.exe.config
Details required:
<system.net>
<defaultProxy useDefaultCredentials="true">
<proxy autoDetect="false" proxyaddress="yourproxy" bypassonlocal="false" usesystemdefault="true" />
</defaultProxy>
</system.net>I completed the above changes back in January this year and all has been working fine since. I dont know if a manual edit of this config is still required or if there is an updated fix to this.
I hope this helps others that are using (or trying to use) a proxy. Aplogies for not updating you all earlier
- RoxanaGRegular Visitor
Thanks cmontoya88 and jswift
We add the list and we change the file but the problema is de same.
We tried configured is in our client, we have a lots of clientes and we never had this problem, but this client have a different infraestructura, have a proxy and one server for the Gateway and other for the data base,
We tried refresh de data flows in witth the client tenant, we configured the user of our client tenant and we don´t have this problem, so… is possible that our user tenant need special permission in de networking, AD, etc?
we done this test whith diferent tenant for check the services limitants in the networking and we can comprovated that it's ok