Forum Discussion

pade's avatar
pade
Icon for Advocate III rankAdvocate III
9 years ago
Solved

SQL Query new advanced setting: "enable sql server failover support"

In the January Power BI Blog, the advance SQL query stiing "enable sql server failover support" was announced. But I can't find any more information from Microsoft about this capability. I know it e...
  • kd7vrc's avatar
    8 years ago

    This is a question I've also had for a long time.  Guy in a Cube answered it in this video about Always On Availability Groups.  When "Enable SQL Server Failover support" is checked, it adds "MultiSubnetFailoverSupport = True; ApplicationIntent = ReadOnly" to the connection string.  Some SQL Server documentation describes the MultiSubnetFailoverSupport option to mean when this option is enabled, if the SQL Server Availability Group fails over from one node to the other, the connection will follow the primary node instead of failing.  ApplicationIntent = ReadOnly is important.  If the Availability Group is configured with it's default settings, it will query the secondary node, leaving the primary node free to process the presumably higher priority load of requests to read and write data that only the primary node can handle.  Applications will read and write faster on primary without your report running there, and your report will read faster with no read/writes in your way on the secondary node.