Forum Discussion
semantic model refresh fail after credential update
- 1 year ago
Hi smeetsh
This usually happens because the password change invalidates the stored credentials in the Power BI / Fabric service. Fixing it in Desktop only helps locally the refresh in the service still uses the old credentials.
Go to your semantic model in the Power BI service >> Settings >> Data source credentials >> re-enter the updated login details for each data source (SQL, Warehouse, etc.). Once those are saved, the refresh should start working again.
If a gateway is involved, make sure credentials there are also updated. In most cases you don’t need to republish the PBIX just updating the service credentials is enough.
Update on this from my end. There was actually also an on-prem gateway connection in there (which I wasn't aware off), even though it wasn't actualy used to pull data, that is the connection that caused an error. We updated the connector it used and that solved it. rohit1991 provided the last bit of the puzzle, much thanks 🙂