Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

PBI Report Server: Some KPI's visuals won't refresh even though matching datasets are refreshing.

After installing the GA (June 2017) Power BI Report Server I've identified a bug for KPI refresh with a Shared Schedule associated with several Refresh Plans.

 

1. I currently have 6 KPI's and one Job.
2. When the Job is executed all 6 datasets shows on their Plans that "Cache was successfully refreshed (time of the execution)

3. Sometimes all KPI's visual show the correct values, some other times only a part ( 2 or 3) KPI's show the correct values and the others show the Old values (even though executing Load Data from Preview shows the correct value)

 

The random way this is acting after several tests lead me to think this is a bug.

----------------------------------------------------------------------------------------------
Even though I keep refreshing the page the visual won't change. I've created a new KPI using the same dataset, refreshed the page, and as you can see they show different values. The updated KPI value (refresh time) is on the right side. The left KPI is the original one that won't refresh.

thanks!

kpi.jpg


Status: New
Comments
v-qiuyu-msft
Community Support

Hi @sbvsv,

 

I can reproduce the issue on my side. Will report it internally, and update here if I get any feedback.

 

Best Regards,
Qiuyun Yu

sbvsv
Frequent Visitor

Thanks @v-qiuyu-msft hope to hear from you soon!

v-qiuyu-msft
Community Support

Hi @sbvsv,

 

Please check if the datasets used by the KPIs are configured by cache refresh plan and refreshed successfully. 

 

q6.PNG

 

Best Regards,
Qiuyun Yu

sbvsv
Frequent Visitor

Hi again @v-qiuyu-msft,

 

Like I said before, all 6 datasets are showing "Cache refresh succeeded" with the correct job execution time on "Last run" like this one:

 

Untitled.jpg

 

I thought you were able to replicate the bug on your side, didn't you?

Thanks!

sbvsv
Frequent Visitor

any news on this? @v-qiuyu-msft

v-qiuyu-msft
Community Support

Hi @sbvsv,

 

I test again in Power BI Report Server August preview version 14.0.600.398, after the cache refreshed successfully like below, back to the KPI the value will be updated. If you leave the KPI here before the cache is refreshed, please refresh the browser to see the update. Please try again in the same version as ours.

 

q6.PNG


Best Regards,
Qiuyun Yu

ludmil
Frequent Visitor

Hi @v-qiuyu-msft.

 

I have exactly the same problem as described by @sbvsv on the August preview version "Microsoft Power BI Report Server Version 14.0.600.398". The cache values are refreshed and part of KPIs (on random base) not. Even I have KPIs using the same dataset - part of them correct and part with the old or even completely incorrect values.

Lola
Frequent Visitor

I have the same issue on SSRS 2016 SP1 CU5: Reporting Services portal. 

KPI's are updating randomly, even KPI's from the same dataset. Cache plans are valid, datasets are updating.

 

Lola
Frequent Visitor
ludmil
Frequent Visitor

Hi @Lola...I just posted a temporary workaround there. Hope it is going to work in your case.