Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Helper III
Helper III

Semantic model on warehouse: Field list item has errors



since monday or tuesday i get the following warning for every table in all semantic models:


Nothing has changed on the warehouse. I cannot find more. 

at first glance, everything seems to work fine... 

Does anyone have an idea what it could be?




Hi @cw88 ,

Apologies for the delay in reply from our side. We have an update from team that above mentioned bug got fixed. 

There was a bug that was misrepresenting direct lake tables and showing them all with this warning triangle. Now fixed.

Can you please check and confirm?

Hope this is helpful.

View solution in original post

Regular Visitor



We are mirroring an Azure SQL Database and encountering the "Field List item has error" issue as shown below. This occurs in Semantic models which are not the Default semantic model. The Default semantic model does not show the errors.


Semantic Model

Activity Error.png


Default Semantic Model

Activity No - Error.png






Don't know if mirroring is a different scenario for the issue.


Just wanted to pass along that the error I was receiving in the semantic model seemed to have been caused because I had removed tables from being mirrored. I was able to fix the issue by deleting the model and recreating after all the necesary tables had been configured for mirroring.



Frequent Visitor

Hello @v-gchenna-msft,


I have the same error on Views, after adding them to the semantic model they have that warning "Field list item has error". Location is North Europe.

Is this bug still active for Views? Do you have any updates?


Thank you

Frequent Visitor

Hi all, 


is this resolved or is there a workaround? I'm getting the same error..

First the field list error: 



Then I can't load data from the model: 



@michaelmll, I worked with Microsoft Support and was told this had been reported internally. I also communicated with someone from the Power BI team recently and sent a video of the problem and was told this had been shared with the engineers.


That said, this has been a problem for several weeks/months now, and I haven't seen this noted anywhere as a known bug. I've been dead in the water on service-based semantic models because of this issue. I'd recommend raising a support ticket with Microsoft as I think the more people that raise it will help make it a priority.


Regarding workarounds, the only thing I've found is literally rebuilding my model in Power BI Desktop and publishing that way, but then you have to either use DirectQuery or Import.

@arpost Thanks a lot for the reply! I'm going to raise a ticket too. 

For Workarounds: I was able to get the default semantic model of the warehouse to work. There it does not show the error. I can connect to that and display data in PBI desktop. But that one would not recognize the relationships I make between my reporting views. 

Your workaround does not work for me. I get an SSL error when I try to connect to the warehouse SQL endpoint. Did you by chance find a solution for that? 



I opened a separate thread for this, but no helpful replies yet.. 

@michaelmll, are you trying to connect via Power BI Desktop? If so, I had to use the SQL Server connector and provide the data warehouse's SQL connection string.

@arpost I see. Unfortunately, it's the same error. 
Which version of PBI Desktop are you using? I was reading about an error in the Feb Version but I've tried December and October too without luck.



Here's my version: 2.128.952.0 64-bit (April 2024)


I used the Azure SQL DB connector just now and didn't get an SSL error; are you using the Microsoft Store version of Power BI Desktop or direct download from Microsoft? I'm running the Store app.

Thanks again! I just removed everything. Reinstalled the same version as you from the store. Tried on a different machine. Created a new Fabric Trial. Created a new Workspace with a new Warehouse. Same Error. 😑

I can use e.g. Azure Data Studio to connect from the same machine to the same warehouse without any problem. I don't get it. 

Maybe you're in a different region? I'm in Europe-West. 

Frequent Visitor

We are also having this issue. We are having this error on Views that we have made in the Lakehouse. When we add a table the error is not showing. We are in west of europe.




Kind regards,


Hi @FritsOrdelman ,

We apologize that you're encountering an error. This is happening due to a bug in our system that our team is actively working to fix. We will update you here once it resolves.

Note the tables need to be added to the semantic model first before a table can be created. Just try to check if the tables are added. You need to add that table to the default dataset objects. In the context menu for the table do the following:



Hope this is helpful.

Hi @v-gchenna-msft,

To be clear about the situation. We are testing with data from a dataverse connection from Dynamics to a new lakehouse. We have now several tables from de dataverse to our Lakehouse connected. We build sevaral view ontop of the tables. Then we created a new semantec model and put the views and some tables in this new semantec model. When we inport a table we do not see the error also we created a date table in Notebooks via Pandas and also that table does not gives an error only he views. Do we need to put all the tables also in the default semantec model? ifso why?

We now put the tables also in the default model but also we have the same errors.


Also we cannot create a new table in the new model.


kind regards,


Hi @FritsOrdelman ,

Apologies for the issue you are facing. This is happening due to a bug in our system that our team is actively working to fix. We will update you here once it resolves.

Advocate V
Advocate V

Not sure if this is the same issue you're experiencing, @cw88, but this may somehow be related to the schema or something. I am also experiencing this issue with a semantic model connected to a Fabric data warehouse. When I try to use the table in a report, I get an error similar to this fake example; the table should be "abr.Store" but is showing "abr.abr.Store". 




Really hoping this gets fixed as this will cripple a DW project on which I've been working for months if I can't add my tables.

Hi @arpost ,

i think this is another problem, as in my case i have no problems in reports etc., just the error sign/message in the semantic model.

Ah. Thanks.

Helper III
Helper III


following a screenshot where you can find the error sign on every table:



I can't tell you steps, it appears at beginning of last week on every existing semantic model without an action from my side.


Hello @cw88 ,

Thanks for using Fabric Comunity.
At this time, we are reaching out to the internal team to get some help on this .
We will update you once we hear back from them.

Hi @cw88 ,

We apologize for delay in response. This is happening due to a bug in our system that our team is actively working to fix. We will update you here once it resolves.

Thank you for your patience and understanding.

Helpful resources

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

Expanding the Synapse Forums

New forum boards available in Synapse

Ask questions in Data Engineering, Data Science, Data Warehouse and General Discussion.


Fabric Monthly Update - May 2024

Check out the May 2024 Fabric update to learn about new features.


Fabric certifications survey

Certification feedback opportunity for the community.