Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
asifraza
Regular Visitor

How to downgrade python version in Fabric Data Science

Hey, 

 

I'm working on a project, in which Python version 3.8 is required, how it is possible to down grade the Python version from 3.10 to 3.8?

As of now runtime 1 and 2 supported the 3.10 python version.

link : https://learn.microsoft.com/en-us/fabric/data-engineering/runtime

Thanks

1 ACCEPTED SOLUTION

Hi @asifraza 
Apologies for an error from my side. I forgot to mention that supporting multiple python versions is on roadmap. Hence it is not available now. I will keep you updated once it is deployed.

Hope this helps. Please let me know if you have any further questions.

View solution in original post

4 REPLIES 4
venkat-subha
Frequent Visitor

Supporting Multiple versions is it ready? If not what is the atlernate approach?

v-nikhilan-msft
Community Support
Community Support

Hi @asifraza 
Thanks for using Fabric Community.

Downgrading the Python version directly within a running Fabric Data Science Notebook isn't currently supported. This is because Fabric notebooks use kernels to execute code, and each kernel is tied to a specific Python version.
Instead you can create a notebook. When creating a new Fabric notebook, you'll have the option to specify the desired Python version. Ensure you select Python 3.8 during this setup process.

If you feel that Downgrading the version feature should be available please feel free to give your feedback.
Appreciate if you could share the feedback on our feedback channel.  which would be open for the user community to upvote & comment on. This allows our product teams to effectively prioritize your request against our existing feature backlog and gives insight into the potential impact of implementing the suggested feature.

Hope this helps. Please let me know if you have any further queries.

Hi @asifraza 
Apologies for an error from my side. I forgot to mention that supporting multiple python versions is on roadmap. Hence it is not available now. I will keep you updated once it is deployed.

Hope this helps. Please let me know if you have any further questions.

@v-nikhilan-msft Thanks for your prompt answer, i couldn't find any option for choosing the python version while creating a notebook, 
Could you please share the steps in more detail, how i can choose the python version?
Please note: i'm using the trial version.

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

Expanding the Synapse Forums

New forum boards available in Synapse

Ask questions in Data Engineering, Data Science, Data Warehouse and General Discussion.

MayFabricCarousel

Fabric Monthly Update - May 2024

Check out the May 2024 Fabric update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Kudoed Authors