Forum Discussion

Syndicate_Admin's avatar
Syndicate_Admin
Icon for Administrator rankAdministrator
5 years ago
Solved

No se puede conectar a la base de datos de SQL Server

hola

Me enfrento a un problema en el que no puedo conectar mi escritorio de Power Bi al servidor SQL de mi cliente. Ya he configurado VPN del servidor de mi cliente en mi computadora portátil. Después de introducir el nombre del servidor e intentar conectarse, se produjo este error:

aidelsrkk_0-1623383043630.png

¿Estoy cometiendo un error en cualquier lugar? o es imposible de conectar a sql de esta manera que no sea instalar puerta de enlace en su servidor?

Por favor, ayuda. Gracias.

  • Syndicate_Admin's avatar
    Syndicate_Admin
    5 years ago

    Hola @aidelsrkk, genial, así es como debe ser 👍 ahora comprobar con la misma dirección de servidor y el puerto en ssms, <servername><comma><portnumber>authentication puede ser cualquiera de windows / autenticación sql según la configuración de su cuenta. Si tiene acceso al servidor, debería funcionar si no, terminaría con un mensaje de error de autenticación

    ** 1433 es el puerto predeterminado para SQL Server a menos que el cliente haya proporcionado cualquier otro puerto para SQL Server.

9 Replies

  • @aidelsrkk, en primer lugar, compruebe si puede conectarse de la misma manera en SQL Server Management Studio.

    Debe asegurarse de que su usuario (windows / servicio o cuenta de usuario) tiene que acceder a la base de datos.

  • @aidelsrkk : como Amit mencionó, intente conectarse usando SSMS primero, sin embargo, podría terminar en el mismo problema desde SSMS.
    El asunto parece más en el networking/firewall lado, cuando mencionaste el servidor es en lado de cliente tendrías que comprobar si eres capaz de telnet el servidor de cmd prompt después de conectar a vpn

    En cmd, puede escribir Telent <ServerAddress><Space><port>Si no pasa, debe pedir al equipo de red del cliente que lo haga accesible a través de VPN

    • Syndicate_Admin's avatar
      Syndicate_Admin
      Icon for Administrator rankAdministrator

      Hola @Washivale , seguí sus instrucciones en cmd, después de escribirlos, me redirige a la página en blanco en cmd. ¿Se supone que debe ser así?

      • Syndicate_Admin's avatar
        Syndicate_Admin
        Icon for Administrator rankAdministrator

        Hola @aidelsrkk, genial, así es como debe ser 👍 ahora comprobar con la misma dirección de servidor y el puerto en ssms, <servername><comma><portnumber>authentication puede ser cualquiera de windows / autenticación sql según la configuración de su cuenta. Si tiene acceso al servidor, debería funcionar si no, terminaría con un mensaje de error de autenticación

        ** 1433 es el puerto predeterminado para SQL Server a menos que el cliente haya proporcionado cualquier otro puerto para SQL Server.