Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Quentin_
Helper I
Helper I

scheduled refresh csv + table combine Error ?

Hello,

I have a problem with the scheduled refresh for my reporting (It works fine on pbi desktop).

For 4 tables of my data model, I need to combine 2 csv (the csv are in a server and I call this files directly by url).

 

Each morning, I have the following message : "Information is needed in order to combine data Table: xxxxxx".

 

----------------

Example call for one combine table :

Table 1 -> Csv.Document(Web.Contents("http://www.xxxxx.fr/my_file_1.csv"),[Delimiter=";", Columns=8, Encoding=65001, QuoteStyle=QuoteStyle.None])

Table 2 -> Csv.Document(Web.Contents("http://www.xxxxx.fr/my_file_2.csv"),[Delimiter=";", Columns=8, Encoding=65001, QuoteStyle=QuoteStyle.None])

Final table -> Table.Combine({#"Table1",#"Table2"})

------------------

How I can solve this problem please ?

 

Thank you,

1 ACCEPTED SOLUTION
v-xuding-msft
Community Support
Community Support

Hi @Quentin_ ,

After researching, I think it might be caused by privacy level. Please follow the steps to check it in Desktop and Service.

In Desktop:

File > Options and settings >Data source settings > Change privacy level to None or organizational

1.PNG

In Service: 

Manage gateways >Advanced settings

2.PNG

Best Regards,

Xue Ding

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Best Regards,
Xue Ding
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
v-xuding-msft
Community Support
Community Support

Hi @Quentin_ ,

After researching, I think it might be caused by privacy level. Please follow the steps to check it in Desktop and Service.

In Desktop:

File > Options and settings >Data source settings > Change privacy level to None or organizational

1.PNG

In Service: 

Manage gateways >Advanced settings

2.PNG

Best Regards,

Xue Ding

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Best Regards,
Xue Ding
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-xuding-msft ,

 

Your solution seems to be the right solution for my problem.

 

Thank you 🙂

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.