Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
magnus_b
Advocate II
Advocate II

"The import #date matches no exports" error in dataflow

Last night one of my dataflows suddenly stopped working, throwing the following error:
Expression.Error: The import #date matches no exports. Did you miss a module reference?

 

I found that the error came from a step where a custom column is created using the #date formula. Somehow the script was changed from:

 

#date(2020,1,1)

 

to

 

#"#date"(2020,1,1)

 

 

I tried changing it back to #date(2020,1,1), but I still get the same error. I also tried creating a new query to see if I could reproduce the issue, and I got the same error. In short, it seems I am unable to to use the #date function in Dataflows at all.

 

Since the issue appeared overnight, with no changes having been made to the dataflow recently, it leads me to believe this might be a bug in Dataflows?

 

I use this very simple query to reproduce the issue:

 

 

let
  Source = Table.FromRows(Json.Document(Binary.Decompress(Binary.FromText("i45WMlSKjQUA", BinaryEncoding.Base64), Compression.Deflate)), let _t = ((type nullable text) meta [Serialized.Text = true]) in type table [#"Column 1" = _t]),
  #"Added custom" = Table.AddColumn(Source, "date", each #date(2020, 1, 1))
in
  #"Added custom"

 

 

Skjermbilde 2021-01-13 kl. 08.52.12.png

1 ACCEPTED SOLUTION
tez
Resolver I
Resolver I

Apparently corrected: For a few hours, my dataflow has been working again without errors, without any intervention on my part.

View solution in original post

4 REPLIES 4
tez
Resolver I
Resolver I

Apparently corrected: For a few hours, my dataflow has been working again without errors, without any intervention on my part.

Anonymous
Not applicable

I've had exactly the same issue as mentioned here. The power query editor will continually change the line back from #date to #"#date"- feels like a really annoying error that should have been caught by a proper testing stage. Presumably this is affecting anyone trying to use '#date' in a data set.

For anyone facing this issue, the workaround that worked for me (as Veles) point to, changing this section:

#date(Number.ToText([FY], 4, 1)

to this:

Date.FromText(Text.Combine({Number.ToText([FY]), "-04-01"})
MarioVW
Advocate I
Advocate I

I've been having exactly the same issue over here. Several dataflows across three different tenants. I already opened a support case with Microsoft, will let you know what they tell me.

Veles
Advocate V
Advocate V

I get exactly the same issue. Dataflow I made a few days ago has suddenly stopped working. Looked through the code and it had changed a #date(...) function to #"#date"(...) and was thinking it was a reference to a step in a query that didn't exist.

 

I did a workaround using the Date.FromText() function but annoying that there has clearly been a back end change that is breaking peoples' queries even though the code is correct.

Helpful resources

Announcements
LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors