Forum Discussion
on-premise data gateway sap bw
Hi Xiaoxin,
The issue seems to have started when we started using the Implemtntation 2.0.
We have installed the Implementation 2.0 connector on the computer running the gateway and now getting the following error:
Unable to connect: We encountered an error while trying to connect to . Details: "We could not register this data source for any gateway instances within this cluster. Please find more details below about specific errors for each gateway instance."Hide details
Activity ID: 0f1e1e33-b5f7-4403-b727-a5f52a9598a3
Request ID: def25b76-7146-789a-c0f0-d2093d99a8e6
Cluster URI: https://wabi-north-europe-redirect.analysis.windows.net
Status code: 400
Error Code: DMTS_PublishDatasourceToClusterErrorCode
Time: Wed Oct 03 2018 15:40:47 GMT+0100 (GMT Summer Time)
Version: 13.0.6781.189
Webmi: Invalid connection credentials.
Underlying error code: -2147467259
Underlying error message: The credentials provided for the SapBusinessWarehouse source are invalid. (Source at dunv-bw7-p2/00/900.)
DM_ErrorDetailNameCode_UnderlyingHResult: -2147467259
Microsoft.Data.Mashup.CredentialError.DataSourceKind: SapBusinessWarehouse
Microsoft.Data.Mashup.CredentialError.DataSourcePath: dunv-bw7-p2/00/900
Microsoft.Data.Mashup.CredentialError.Reason: AccessUnauthorized
Microsoft.Data.Mashup.MashupSecurityException.DataSources: [{"kind":"SapBusinessWarehouse","path":"dunv-bw7-p2/00/900"}]
Microsoft.Data.Mashup.MashupSecurityException.Reason: AccessUnauthorized
gateway3: The gateway is either offline or could not be reached.
Troubleshoot connection problems
Hi, has anyone else had an issue adding SAP BW to the Enterprise Gateway since using Implementation 2.0?
Thanks
Mike
- Anonymous8 years agoNot applicable
HI Anonymous,
I test with implantation 2.0 connector without your issue, it works well on my side.('import' mode with sap warehouse application server)
>>Underlying error message: The credentials provided for the SapBusinessWarehouse source are invalid. (Source at dunv-bw7-p2/00/900.)
In addition, it mentioned credentials error in error message, have you test on desktop side to ensure your credentials works? Is there any changes on your credentials?
Regards,
Xiaoxin Sheng
- Anonymous8 years agoNot applicable
Hi,
Thanks for testing.
My credentials work fine on desktop side. We need to move the gateway to a new server so will see if the issue still persists after that.
Regards
Mike
- Anonymous7 years agoNot applicable
We have the same problem since moving to the gateway 2.0 connector (I did have it working with 1.0).
I have also installed the latest (March 2019) version of the gateway and the problem persists.
I have opened a call with Microsoft and they have traced it to the language (EN in my case) not being passed through as it is in Desktop. This causes SAP to reject the connection.
However, in the gateway connector there is no option to set the language.
Does anyone know if it is possible to set the language on the SAP side of the connection?