Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Gaurav_84
Helper I
Helper I

full report attachment greyed out

Hi Experts

 

I have Powerbi Premium user license & i am trying to use "full report attachment" option in powerbi but it is still showings as greyed out. I tried creating Premium workspace & then try same thing still its greyed out. 

Any idea what is missing?

Gaurav_84_0-1629693609698.png

 

 

1 ACCEPTED SOLUTION
Gaurav_84
Helper I
Helper I

This is resolved now, need contributor role along with admin role.

View solution in original post

9 REPLIES 9

Mine still not working....

I:

1. Upgraded to Premium per user workspace

2. Have dashboards with less than 25MB and less than 20 pages

3. Have admin and Contributor roles in the premium workspace

 

but the report attachment is still greyed out. Any ideas on how to fix this?

andrejmfreitas_0-1654776922915.png

 

Was the report created before you upgraded?  If so make sure you've created a premium workspace.  You should see an icon next to it that looks like a diamond.  Make sure your report and dataset are both in that workspace.  I had some issues getting a report to migrate workspaces correctly so I ended up re-creating the report in that premium workspace and that did the trick.

 

acannon_glfp_0-1655135294389.png

 

Make sure your report and dataset are both in that workspace.  -> This fixed my issue.

I had a copy of a report from another workspace without the database.

 

Thanks,

Andre

Gaurav_84
Helper I
Helper I

This is resolved now, need contributor role along with admin role.

How can you assign both roles to yourself as a user? I have admin assigned..but when i attempt to add myself as a contributor it just reverts to contributor rather than keeping both. 

@Gaurav_84 it would be helpful if you elaborated on how to fix/add the contributor role to an admin role. 

I'm in the same boat.

I need to send a reporr in pdf format to a non-Power BI user.  I am a Premium user and the report is saved in a premium workspace however, this is still greyed out.  

Thanks

Either it's not working for me or I'm not understanding the solution.  I can't add both roles to the same user.  I've added to users 1 with admin role and 1 with contributor role but this option is still greyed out for me.  I also created a premium workspace and am using a premium user account.  Not sure what else to try.

v-easonf-msft
Community Support
Community Support

Hi,  @Gaurav_84 

The size of the report attachment must be 20 pages or less, and the attachment must be less than 25MB regardless of the number of pages. 

For more informarion, please refer to this blog:

Full report attachment for subscriptions for Power BI Premium reports now available 

7.png

 

Best Regards,
Community Support Team _ Eason

AbhiSSRS
Solution Sage
Solution Sage

Is it a large file? 

Please check if the criteria are met as per below link :

https://docs.microsoft.com/en-us/power-bi/collaborate-share/service-report-subscribe?WT.mc_id=DP-MVP....

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors
Top Kudoed Authors