Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
gooranga1
Power Participant
Power Participant

enterprise gateway refresh fails

since last Thursday we are experiencing refresh fails on some of our datasets. These always worked okay up until last week and now we are getting a lot of intermittent fails. The fails come with no failure messages.

 

They don't really follow a pattern either. Sometimes 07:00 am refresh works one day and fails the next. Sometimes 07:00 am refresh works and the 08:00 am fails. If I go in and manually refresh they always work.

 

We are using import query queries into pbix files from SSAS an SQL server.

 

Anyone else experiencing this?

 

RefreshFails.PNG

8 REPLIES 8
ZLJ
Advocate II
Advocate II

All of our reports using a Data Gateway are currently failing.  They are ok on a Personal Gateway though.

 

I think it might be to do with the alert on here:

https://powerbi.microsoft.com/en-us/support/

 

Very annoying though, as we've just got alot of people used to using it regularly!

 

gooranga1
Power Participant
Power Participant

Are you still experiencing issues with data refresh? It seemed to get better on Friday for us but then 80% of our refreshes failed this morning? 

 

The message isn't there anymore about the refreshes.

I ended up setting up a new data gateway on Wednesday last week, and repointed all my reports.  The old one still isnt working at all.  The New one worked find up until around 8am this morning, at which point all my reports failed for about an hour.  They are all working fine again now.  I think it was a different issue, as the error message was non-existant this time, and the Gateway was showing as connected during that hour.  

Is yours working now?

gooranga1
Power Participant
Power Participant

We are still getting failures even though the message on the support page is that PowerBi is running smoothly now.

 

It's always the same datasets that fail but not all the time. Sometimes a manual refresh fixes it and sometimes they also fail.

 

I have raised a ticket.

Have you had any news relating to this?  I am experiencing a similar issue.  Sporadic failures, however I can open the file in the desktop client, do a refresh and republish.  All of these utilize an on-premises gateway on an azure virtual machine.  Since this problem began I updated the gateway to the latest version and restarted.  Any ideas?  May open a ticket myself.

gooranga1
Power Participant
Power Participant

Thanks for getting back. Most of them do seem to have run now but a few still are failing.

 

I will open them in powerbi desktop save them in the new version and re-publish in case it's something to do with the new version.

We are still getting failures. I have opened a case with support.

gooranga1
Power Participant
Power Participant

Ah thanks! I didn't spot that. Glad it's not just me breaking things. 🙂

 

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.