Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
OneWithQuestion
Post Prodigy
Post Prodigy

browser cache issues with updating fields in visuals

Using the Power BI service, I have run into issues when I update a report in desktop and then deploy it.

 

If I change a visual, specifically if I change the columns in a visual, some user's browsers don't seem to reload their browser cache and throw an error.

 

The visual will have an X with a circle around it and see "Fields that need to be fixed  Something's wrong with one or more fields:...."

 

However, other users have no issues.

 

It only seems to apply to users that have opened the report earlier, then closed their browsers, then come back to the report after a change was published.

 

Has anyone else had this problem?

11 REPLIES 11
jrussell0917
Regular Visitor

Has this issue reared it's head again?  We have reports that have been updated, published to the applicable workspaces and updated the app's and they don't update.  The dashboards aren't updating either to match what's in the workspace.  It just started happening again. 

bigjohnny7
New Member

Adding support to this issue. 

It's a major problem for me, particularly in one of our key dashboards. 

It's a dashboard that is constantly changing - in terms of layout, formatting, fields, etc - but when my stakeholders open it online, this weird caching issue means that the first thing they will see is the first page of the dashboard, but it could any version of the dashboard that has been published over the last several months. The underlying data will be correct, but it will not be the most up-to-date version of the dashboard (in terms of layout, formatting, fields, etc) that I have recently published. 

A workaround seems to be to click that page on the left hand 'Pages' menu bar, and this then seems to wake the dashboard up and renders to the latest version. 

Yet another Power BI issue - and I agree with the above comments: asking stakeholders to clear caches, or anything like that, is not optimal or sustainable behaviour. 

KPana
New Member

Is there a solution to this issue as I recently experienced the same problem?

 

One user of a Power Bi report sees one set of data, while another sees other values for the same period of time and the same overall filters. This happens from time to time and the problem is solved only when the browser cache data is cleared.

 

While this is a workaround solution, I cannot expect the users to clear their cache just to see correct data as it undermines the report validity.

 

Could you please advise if there is another solution to this kind of problem?

 

Thanks!

Anonymous
Not applicable

I can confirm this is still an issue. This just happened to me, and all I had to do was publish a differently named version of the report. I don't believe this is a browser cache issue, because I disabled the cache in Chrome, did a refresh and still couldn't see some fields. The fact that the report needs to be saved with a different name suggests that it is a report server issue.

jrenner is correct.  I'm having this issue as well with my on-prem server.  This is for all my users with templates that have been saved recently.  I don't think it's talking to the new dataset schema somehow.  maybe cached queries, because i have to restart the service to fix it, or that is coincedentally fixing the issue.  I haven't quite figured it out yet.

I have recently experienced this problem which has manifested in 2 ways:

(1) the data in the report has been updated, but the visual does not show the latest data
e.g. The x-axis has a missing date, and after adding the data for that date, the visual *still* does not show data this on the visual
(2) the visual has been updated, with different formatting and this does not appear for some users
e.g. the Date slicer is changed from relative to absolute i.e. "last 6 months" to "YYYY/MM/DD to YYYY/MM/DD" and some users still see the previous slicer formatting.

Any help or suggestions will be appreciated.

Same problem here.
Could you please advise if there is another solution to this kind of problem?

SimenJ
Frequent Visitor

We are experiencing similar problems. Using incognito mode in Chrome solves the issue, but in my view that is only a workaround. You cannot expect a regular user to do this.

 

Another serious incident we have had which is probably related to this, is that the report would show incorrect data. We have had incidents where the data in the underlying source (Dynamics 365 CRM) have been changed, but the report would show the old status for some users (who presumably had used the report previously) unless they used incognito mode in Chrome.

 

This is something that the PBI team should look into, as it undermines the trust in the product.

v-shex-msft
Community Support
Community Support

HI @OneWithQuestion,

 

Do you mean schedule cache refresh for direct query mode? If this is a case, you can take a look at following link to know more about this.

Announcing Custom Cache Refresh Schedules in the Power BI Service

 

In addition, I'd like to suggest you clean up cache files or use 'refresh now' feature to work through this issue if it work on your side.

 

Regards,
Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.

Sorry, I mean actual cache on the web browser of the page.

 

For example error.PNG *red arrow mine

 

Out of roughly 10 users, 6 saw no issue and 4 saw that black X.

 

Clearing browser cache did nothing, and I could not get the issue to go away.

 

I re-published the report a few times, no change.

 

Finally I published a copy of the report to a new location (as a new report, not overwriting the existing) and that worked for everyone.

 

What I didn't understand is why that behavior took place.

 

Are there multiple PowerBI servers in the service and after you deploy a report it takes time for them to all "synchronize"?

Anonymous
Not applicable

I have seen other cache issue with Power BI and a work around is to use Google Chrome in an Incognito window. This will prevent caching issues on the browswer.

 

This one time was specifically with the Schedule Refresh intervals.

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors
Top Kudoed Authors