Showing results for 
Search instead for 
Did you mean: 
Frequent Visitor

Workspace Contributor Publishes Report but can't manage permission

I have created a workspace for allowing team members to publish and share reports.  I don't want to make the members WS admins but would like to make a report publisher have the ability to grant access to the report.  When a member publishes a report, I, as an admin of the workspace, can view the report "manage permissions" screen as attached and the member publishing (green) is not listed as an owner and is not able to see the manage permissions.  How can I get the member to be the owner and the ability to use the manage permissions screen.  Any recommendations greatly appreciated.








Super User
Super User

Hi @brennum 

For a contributor to a workspace to share access to a report in that workspace they need to be given "Reshare" rights.

This is done at a report level withing the Workspace. 

As Admin, Click on the "More Options" on a Report and select "Manage Permissions"


Then in "Manage Permissions" select "Direct access", click on the "more options" (...) next to the contributor you want and click "add reshare".


That Contributor will then be able to share the report from the Workspace with others.

I've not found a way to do this for the whole Workspace. It needs to be done on each Report.

Hope this helps





Helpful resources

PBI Sept Update Carousel

Power BI September 2023 Update

Take a look at the September 2023 Power BI update to learn more.

Learn Live

Learn Live: Event Series

Join Microsoft Reactor and learn from developers.

Dashboard in a day with date

Exclusive opportunity for Women!

Join us for a free, hands-on Microsoft workshop led by women trainers for women where you will learn how to build a Dashboard in a Day!

Top Solution Authors
Top Kudoed Authors