Showing results for 
Search instead for 
Did you mean: 

Fabric is Generally Available. Browse Fabric Presentations. Work towards your Fabric certification with the Cloud Skills Challenge.

Helper I
Helper I

Why is my visualization "read only content?

Hi all,

My team is trying to move to sharing datasets; we all have pro licenses and all of our workspaces are Premium. We have a dataset with an associated report, both in workspace/app A, that is also beng used as the basis of another report in workspace B. Now my dev would like to pin one of the visualizations from the report in workspace B to a third dashboard, but when she does so the Pin icon is grayed out and it tells her that "read only content can't be pinned." When I use any of my accounts, I'm able to pin that same visualization. 


I have tried *every imaginable* combination of dataset and app permissions to get my dev the ability to pin this viz, and I can't make it happen, and it's driving me crazy. Even when I had her set as an Admin for workspace A and B, no dice. What am I missing??

Community Support
Community Support

Hi , @martensf 

Has your problem been solved ? If it has been solved, then please consider Accept it as the solution to help the other members find it more quickly.


Best Regards,
Community Support Team _ Ailsa Tao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.



Resident Rockstar
Resident Rockstar

There are a few possible scenarios here:
1 - That dev has the role "Viewer" in the workspace where the report is located

2 - If the report is shared to the dev ( dev not accessing the report through a workspace ), then the sharing permission is only set to view and no build permission is given


Pinning is basically creating content, and you can create content if your role in the workspace is higher than viewer.


When a report is being shared to a person, the sharer has the ability to configure the permission i.e read only or build. If build permission is unchecked, then you can only view it.



Thanks for the reply! I just checked - she's a workspace admin in the workspace where the report is located, and she's a member of an AD group that's a Contributor on the workspace the source dataset is in as well as having individually-granted Build privileges for that dataset. So it's not that, and she's accessing the report directly through the workspace, not through a share link. She's also the person who originally built the report that she's trying to pin the visualization from, so I wonder if she maybe connected to the dataset the wrong way when she was building it in Desktop?

Hi MArtensf,
Seems like you have set everything up correctly. The dev could be a victim of a bug that has occured before.  This is definitely not normal behaviours and I would send a ticket to Microsoft Power BI.

A workaround that could work is to delete the dataset and report, and publish a "fresh" datatset and report. This would hopefully remove any bug cached in the previous datset/reports set. OR just create a copy of them by publishing it again under a different name.

This maybe a silly question, is the dev's pro license still valid?

It is. I'll put in a ticket. Thanks!

If you or Microsoft finds out the reason/solution, do share it with us!

Helpful resources

PBI November 2023 Update Carousel

Power BI Monthly Update - November 2023

Check out the November 2023 Power BI update to learn about new features.

Community News

Fabric Community News unified experience

Read the latest Fabric Community announcements, including updates on Power BI, Synapse, Data Factory and Data Activator.

Power BI Fabric Summit Carousel

The largest Power BI and Fabric virtual conference

130+ sessions, 130+ speakers, Product managers, MVPs, and experts. All about Power BI and Fabric. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors