Forum Discussion
While Scheduling the Power Bi reports in service facing error
Adding to above errors these reports are working absolutely fine in Service and users acessing those with out any issue, but when we create bulk subscriptions with multiple reports and multiple filters with in reports we are facing above errors.
Hi, naveenanda_vam
Thank you very much for the very useful information. I guess the cause of the problem lies on the visual querying data source. In the official Power BI documentation, it is mentioned:
Set visual query limits in Power BI Desktop - Power BI | Microsoft Learn
When you try to subscribe for more than one person, the memory is exceeded. As far as we know, the content of a Power BI capacity isn't unlimited. Each license has a memory limit. A single person can't outdo it, and multiple people will send query requests to the data source in real time, which will consume exponential increments, causing us to quickly reach our limit.
Here's what we can do:
1. Try scheduling your subscription for a time period when no one is watching the report. Watching reports also requires memory that consumes your capacity for a live connection.
2. Try to reduce the number of people you subscribe to at a time, and don't add all of them to your subscription at once.
3. I think this one is the most user-friendly, try to group different groups of people, and then the important people will arrange the subscriptions individually. People who need to see the same content will only subscribe once and then forward an email to the group (or subscribe directly to the group).
The above method will be a good way to circumvent this limitation. If you still have any questions or need more support, please feel free to let us know. We are more than happy to continue to help you.
Thank you for your patience and look forward to hearing from you.
Best Regards
Jianpeng Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.