Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Frequent Visitor

When adding user in gateway, list keeps spinning and nothing happens

We have added a list of users to serveral gateways we have configured. But when we want to add a new one (by selecting the user via the email adress and clicking 'add'), the list keeps spinning. We've waited for several minutes but nothing happens.

is there something like a maximum in 1 gateway, or the total of gateways? Does it have to do something with licences? Or is there antother reason why this is not working?

(it's not the first person we add, all gateways have several (but not the same) users)

Frequent Visitor

Hi all,


In the meantime we have contacted Support, and we are in touch with producthouse at the moment. They have found the issue, and there will be a fix available soon, ETA March 30th 2018.

So this means that this is not something we could fix ourselves, and as far as I know there is no workaround available.


Thanks for you help and thoughts anyway!




For the one data source I had issues with, I have tried deleting and recreating it, It worked fine. Yours could be different issue but worth giving a try meanwhile MSFT fixes it. 


Hi @pauline020,


Does this problem only occur to some specific users? Were you able to add them to a different data gateway?



Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-yulgu-msft  I have more than 10 data sources in the Gateway. it works fine in all the data sources but one. I have removed an user and trying to add others, it keeps spinning. I tried to add back the user I have removed, same issue, it keeps spinning. 

I am still able to add the users in rest of the data sources. This data source which I am not able to add is connecting to SSAS (similar to the ones which are good)

Not applicable

Hi @v-yulgu-msft,


Similar issue here. I can not add new users our PROD source anymore. The dotted circle keeps on spinning an nothing happens.

Adding the same users to our ACC source is working fine. Both sources are SSAS cubes via on-premisses datagateway.


At first I was thinking about a limit on the number of users, so I removed one. Turns out I can't even add the removed user back to the list. I also tried restarting the on-premises data gateway service, but that did not resolve the issue.


Ideas are more than welcome,




Hi @v-yulgu-msft,


Thanks for your reply! At the moment it occurs to all users, I can't even add an existing user (that was already added to Gateway 1) to another gateway (for example Gateway 2).

At first, when we could not add user A, we tried user B and this worked. But after that, we could not add any user anymore. Then we deleted another user from that gateway and we were able to add an existing user. But when we tried that again, we could not. So it all looks more or less random, and we cannot really determine the root cause.

Any ideas?


Thanks again!


Helpful resources

Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

Top Solution Authors