Showing results for 
Search instead for 
Did you mean: 

Fabric is Generally Available. Browse Fabric Presentations. Work towards your Fabric certification with the Cloud Skills Challenge.

Frequent Visitor

Web URL connection appearing twice

I have added a url connection to my model and it has appeared in the list of connections twice 




If I map it in the top box it clears the bottom box and vice-versa


I also get the message at the top of the settings page saying:

"Please make sure your data gateway (personal mode) is installed and configured properly."


The gateway is not in personal mode (don't know why its wanting a gateway for a URL)


Anybody have any suggestions?

Frequent Visitor

OK. Overnight the error changed, not sure what changed but we have a different error now


Screenshot 2023-11-22 094618.png

Error now says "We timed out waiting for javascript to retrieve the contents of the web page."


Ok. Now it looks like the error is about getting the data from the web. Are you scrapping the web? the code behind it is taking too long and there might be a timeout for the function you are using. For example, if you are using web.browsercontent, you can read there are parameters to help you wait longer

Check how long it takes from power bi desktop. If it takes too long there might be a problem, if it's fast you can just change the parameter of the function. Read the examples of the link to know better the power query code.

I hope that helps

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Happy to help!

LaDataWeb Blog

Super User
Super User

Hi. My guess would be the UI has change and it now let's you pick how you want to handle the cloud source. Traditionally the way to build a semantic model that has onpremise and cloud sources would be activating this checkbox at the Gateway settings:



When that check wasn't turned on the only way to refresh a cloud source was using the gateway. However when the check was there, you could not configure anything on the gateway section and just go to "Data Source Credentials" section at the same page and edit credentials of the cloud source. 
If you want the cloud to keep in cloud. I would check that box and just edit credentials. Forget about the source showing there on the gateway.

I hope that helps,

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Happy to help!

LaDataWeb Blog

Helpful resources

PBI November 2023 Update Carousel

Power BI Monthly Update - November 2023

Check out the November 2023 Power BI update to learn about new features.

Community News

Fabric Community News unified experience

Read the latest Fabric Community announcements, including updates on Power BI, Synapse, Data Factory and Data Activator.

Dashboard in a day with date

Exclusive opportunity for Women!

Join us for a free, hands-on Microsoft workshop led by women trainers for women where you will learn how to build a Dashboard in a Day!

Power BI Fabric Summit Carousel

The largest Power BI and Fabric virtual conference

130+ sessions, 130+ speakers, Product managers, MVPs, and experts. All about Power BI and Fabric. Attend online or watch the recordings.

Top Solution Authors