Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
edwardrmiles
Helper III
Helper III

We cannot convert the value "[Record]" to type Record causes refresh fail

Hi, I'm trying to schedule a refresh but it is failing with this error:

 

"We cannot convert the value "[Record]" to type Record"

 

My data sources are Dynamics CRM and SQL Server

I'm using a Personal Gateway, it is turned on and recently updated

I can refresh and publish from the desktop

Data Privacy is set to Organization for both data sources

 

Any idea how I can identify where the problem is?

 

 

1 ACCEPTED SOLUTION

Hi @edwardrmiles,
Do you have fastcombine turned on on the personal gateway? If not here's a link on how to do it: https://powerbi.microsoft.com/en-us/documentation/powerbi-refresh-enable-fast-combine/#turn-on-fast-...

View solution in original post

15 REPLIES 15
geomath
New Member

What was the solution here? Auto refresh is failing with "Failure details: We cannot convert the value "[Record]" to type Record. "

SWoloshin
Regular Visitor

I have this error AND the only datasource in use is Dynamics 365 CRM.  I am not using a data gateway because one is not required for this online source.

 

Like others in this thread, the odata credentials are not showing errors and the privacy level is set to organizational.  Any ideas?

any resolution for this? having similar issues.
v-shex-msft
Community Support
Community Support

Hi @edwardrmiles,

 

Based on test, Dynamic CRM use the connect directly mode to link, this datasource can refresh directly without a gateway. After publish to service, you only need to modify the credentials.

 

Capture3.PNG

 

Capture.PNGCapture2.PNG

 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.

 

Thanks @v-shex-msft, but the option to connect directly isn't availble to me as the model blends OData with SQL Server on-prem. See error message below

 

refresh issue.PNG

 

 

 

 

 

Hi @edwardrmiles,
Do you have fastcombine turned on on the personal gateway? If not here's a link on how to do it: https://powerbi.microsoft.com/en-us/documentation/powerbi-refresh-enable-fast-combine/#turn-on-fast-...

Getting same issue .Our data source is cosmosDB, So we haven't used any gateways as we are already in cloud

Hi @dimazaid

 

I have the same error but for 2 differents sources : CRM & Sharepoint.

On Power BI Desktop the refresh works great.

On Power BI Service it doesnt. I supposed that since these sources are in the cloud, they don't need to pass by the on-prem gateway. 

Moreover, I use a On-Prem gateway so the "fastcombine" doesn't count ( and my setting is already set at Ignore ).

 

Do you have any ideas about my problem? Thanks,

 

1.png2.png3.png

@DAN were you able to finda solution for this? We are having the exact same issue with one of our reports. 

Anonymous
Not applicable

I have the same error.

Only instead of "Record" it says "Table"

 

The Fast Combine fix didn't help me though. Still having this error.

Can it be because I run a fast combine from a different computer?

 

 

The Microsoft Support heldesk has been silent for over 1.5 weeks now, regardless of constant follow-ups.

Hi @Anonymous,
What do you mean you're running the fastcombine on a different computer? Are you using the personal gateway? This needs to be configured on the same machine where your gateway is running. 

Anonymous
Not applicable

FastCombine is on the same machine as Personal Gateway. But that's not the machine I'm working from primarily. Which shouldn't matter

Sorry for the delay. 
I need to learn more about your queries and setup. Please msg me here so we can connect via email. 

Thanks!
Dimah

Thanks @dimazaid, it worked!

whats the solution?

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors