Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Anonymous
Not applicable

Visual level filter not working in app

I have published a report to a workspace, then created an app. However, in one of my reports, I have a visual level filter that works fine in the workspace, but when I publish to the app, the filter disappears and shows all data.

Has anyone come across this issue before and, if so, how can it be fixed?

1 ACCEPTED SOLUTION
Anonymous
Not applicable

"Publish it again with a different name.." It might sound silly, but it worked for me.

View solution in original post

22 REPLIES 22
aizamkamadin
Helper II
Helper II

any solution guys? thanks

ZC1
New Member

I know this is old, but I found a solution that worked for me.  I believe the issue may stem from persistent filters.  Hitting the "Reset to default" button in the app fixed the visual level filters.  I have now disabled persistent filters by default in the report settings.  The blog post I linked above explains how to do this.

hello_MTC
Helper III
Helper III

Solution is, delete the report from workspace and re publish it with the same name or different name. It will show exactly like PBI Desktop.

Anonymous
Not applicable


@Anonymous wrote:

I have published a report to a workspace, then created an app. However, in one of my reports, I have a visual level filter that works fine in the workspace, but when I publish to the app, the filter disappears and shows all data.

Has anyone come across this issue before and, if so, how can it be fixed?


Yes I was having a similar issue. My problem was I had a date column that I wanted to use as a report level filter to my report on Report Server. The date was duplicated from a date/time column and renamed month, I had just the month transformed from the original. When I was working in desktop it would work just fine, but when I updated the report in the Report Server it would say: “this filter can't be used since the corresponding field is invalid”. Being very confused I started trying all kinds of different strategies. I eventually saw someone on this site say: “publish it again with a different name and try that”. That solution worked for me. Give it a try at the very least. It seems this is an ongoing issue and for someone who isn’t good at figuring out solutions, it would be a nightmare to solve.

Anonymous
Not applicable

Same here..publishing it again with a different name worked for me.

Anonymous
Not applicable

Hi, I am facing exactly the same issue with a report level filter working fine in PowerBI Desktop and sometimes disappearing in the published report in app.powerbi.com. Sometimes the filter is there, and sometimes it is not there anymore for a same user.  Several users have experienced the problem. Other users have not had the problem yet using the same report. I haven't figured out yet how to reproduce the error consistently. Has the issue been picked up by the support team?

Regards, Karim

 

craigh
New Member

Did anyone ever get to the bottom of this? I am having the exact same issue. I did note that I was using bookmarks in the report. Perhaps those are causing corruption with the filters somehow?

Anonymous
Not applicable

"Publish it again with a different name.." It might sound silly, but it worked for me.

csm
Frequent Visitor

The real issue, as ZC1 points out, is persistent filters being saved and re-applied when the report is viewed in the service.  That's why publishing again with a different file name works to restore the defaults.  You can reset filters anytime using the green arrow provided in the top right corner (Reset filters, slicers, and other data view changes you've made).  Especailly during development, persistent filters can be disabled under Options > Current File > Report Settings.

yes, it may work but it can't be called a "solution"...

 

every time you publish with a different name you lost all the automatic update configuration so you need to reconfigure it. This is really annoying and time consuming when you have more than 10 production reports (each of them using information from multiple sources that you need to add again one by one through the gateway selected...)

 

please Microsoft... This bug MUST be fixed !!

froy
Frequent Visitor

in case it helps someone...

 

after a lot of investigation I found that the bug only appear when using relative time data filtering. For example, "this visual only show data from the previous 12 months". In the app, when the report is affected by this bug, this visual will show all range of data (not only 12 last months)

I have change my reports through a lot of "bad" data modelling (like creating calculated field as checkpoint like "this month" or "other month" in order to be able to filter later by this field without being a relative filter) in order to not use this kind of filters and now it all works fine.

I dont know why Microsoft is not fixing this... it makes reports losing a lot of power...

Click the 3 dots to the right of the bookmark and uncheck "data".  That should work

v-frfei-msft
Community Support
Community Support

Hi @csm,@Anonymous 

 

Based on my test using the latest version of desktop :2.63.3272.40161 64-bit (October 2018). I cannot reproduce your issue here. Did you publish the report to the same workspace?

 

Maybe you can create a support ticket for help here.

 

https://powerbi.microsoft.com/en-us/support/

 

Support Ticket.gif

 

Regards,

Frank

Community Support Team _ Frank
If this post helps, then please consider Accept it as the solution to help the others find it more quickly.

Thanks for checking Frank.  Yes, I was publishing to the same workspace.  I just tried again and found that when replacing the existing dataset, the visual filters are not applied although any other changes to the report are updated. If I SaveAs and publish with a different name, then the new report matches what I see in the desktop app.  

How did you get this to work?  I tried setting the visual filter and doing a SaveAs, but with the same result.  When the report is viewed in the workspace, the visual filter is unset

csm
Frequent Visitor

Our app space is in a shared capacity so maybe different for premium?  Not that it's a viable solution, but if I Save As and republish within the Desktop app, the report with the new name within the workspace does correctly show the visual filter.

Anonymous
Not applicable

Hello there, 

 

I am having the exact same issue. I think that there is a malfunction that needs to be checked by the support team. I just opened a new topic here in the community with this issue. 

Visual filters applied on Desktop - DONE 

Visual Filter applied on Microsoft Teams - Done 

Visual Filters NOT applied in Power BI service. 

 

Just "Saved As" new file and it worked. This is a workaround obviously, there is something that requires further investigation. Keep us posted Support Team. Cheers to all. 

 

csm
Frequent Visitor

Same issue here.  Visual level filter is applied in the desktop app (left), but isn't applied once published to app workspace (right).

Version: 2.63.3272.40461 64-bit (October 2018)

 

DesktopWeb

rraymond
Regular Visitor

Same issue here.  Visual filters work perfectly in the desktop, but when I publish to the premium workspace, any visual level filters that I've applied become unfiltered.  Hope this gets fixed soon

ljohnston
Regular Visitor

Did you ever figure this out? I'm having the same issues. When I publish to My Workspace, the visual level filters work perfectly. When I publish the same file to my premium app space, some of the filters work and some don't. 

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.