Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
jonathanpatten
New Member

Users having trouble accessing one of my reports in the app

I have a report in my app that my users are not able to access.  When they click on it they get the message 

jonathanpatten_0-1708116930950.png 

I have shared the link to the report in the workspace and they are able to see it there.  I also added them to both the semantic file and the report file. I have even deleted the report from the app and re-added it but nothing seems to work.  There are other reports in the app that use the same semantic file that they are able to view.  It is only that report that I am having the problem with.  Any help would be appreciated!

 

1 ACCEPTED SOLUTION
aj1973
Community Champion
Community Champion

Hi @jonathanpatten 

The message is clear, the user needs a permission to the underlying dataset. If the dataset is a composite model meaning in contains more than one dataset or item then user needs to have permission on it/them.

 

Regards
Amine Jerbi

If I answered your question, please mark this thread as accepted
and you can follow me on
My Website, LinkedIn and Facebook

View solution in original post

5 REPLIES 5
nickchobotar
Skilled Sharer
Skilled Sharer

@jonathanpatten   Anothner idea here would be to check if you have any rules for the RLS (row level security). 

aj1973
Community Champion
Community Champion

Hi @jonathanpatten 

The message is clear, the user needs a permission to the underlying dataset. If the dataset is a composite model meaning in contains more than one dataset or item then user needs to have permission on it/them.

 

Regards
Amine Jerbi

If I answered your question, please mark this thread as accepted
and you can follow me on
My Website, LinkedIn and Facebook

Nothing seemed to work.  I found an older version of my PBI file and used that.  I  had to make all the changes to my reports since then but that solved the problem. Not totally satisfied with the solution but at least it got things working again.  Thank you all for looking into it though.

Thank you for your suggested solution, Amine. I was working with Jonathan on this (when we got stumped, I directed him here).

 

The dataset is a Power BI direct query, and he already added the users to the dataset (with read permissions on the semantic model). That one Power BI dataset is the only data source for the report. Also, there are a few different reports that all use that same semantic model, but only one gives the error--and the error only occurs when viewing the report in the app, not when viewing the report directly.

Jonathan ! do I know you guys? 😉

 

Did you add users to Audiences in App?

 

Regards
Amine Jerbi

If I answered your question, please mark this thread as accepted
and you can follow me on
My Website, LinkedIn and Facebook

Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors