Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
maanlander
New Member

Upload .pbix from sharepoint grey (but I have a E3 license)

My organisation has been using the "upload .pbix from sharepoint" feature for some time and this was going fine until recently the feature has been greyed out.

 

maanlander_0-1678782494629.png

 

The information box says we need a sharepoint license, but that's included in our E3 license right?

 

When I go to portal.office.com and see what subscriptions I have, I see this:

maanlander_1-1678782587997.png

 

Do I need more rights for sharepoint uploads? Maybe a setting the admin has to change?

 

Any help will be appreciated

17 REPLIES 17
v-tangjie-msft
Community Support
Community Support

Hi @maanlander ,

 

This issue has been submitted internally.

Workaround :1. Check if disabling MCAS works i.e, access powerbi using https://app.powerbi.com instead of https://app.powerbi.com.mcas.ms 

2. Check if disabling useRootUrlFilePicker feature switch works by adding ?useRootUrlFilePicker=0 to the url

 

Please be patient to wait for fixing. If there is any news, I will update it here.

 

Best Regards,

Neeko Tang

MaxMateria
Regular Visitor

On the Power BI web the options are disabled, on the Power BI app within Teams, they appear enabled

VetteJelle
New Member

Recently I had contact with someone with someone from the support egineering team and they said the following:

 

I had the chance to look internally for this scenario and was able to see that there is currently two possible workarounds to test, so I would like to request you to do this.

 - Check if disabling useRootUrlFilePicker feature switch works by adding ?useRootUrlFilePicker=0 to the url

 

When I add this to my url the button suddenly works:

VetteJelle_0-1683277491856.png

 

While this is a workaround, it at least works. So for anyone in the future with this problem, try adding ?useRootUrlFilePicker=0 

Thank you for posting the reply, this has worked for myself. Good to have a temporary fix in the meanwhile.

eduard1
Regular Visitor

Hello all, and especially the support team,

Like Ian, about since a month some users experience problems with 'Upload PBIX to Sharepoint or Onedrive' from https://app.powerbi.com: the option is greyed out with a message that a subscription is required, and this was working for them before. We send in a Premium support ticket to the Sharepoint-team as well last week, but no answer as of yet.

 

Two solutions (O365 license, UseRemoteAPI's) have been tested on Chrome/Edge/Firefox, and the option from the workspace is still greyed out for some users, and the sync to Onedrive has been disabled. All our projects with this method are disrupted.

1. Usergroups have a M365 and Power BI Pro-license. The logged in users are members of the groups. 2. On the site root level and library permission level “Limited Access”, the permission “UseRemoteAPIs” have been set. 3.  Granted access to the same user groups as in Power BI and thus propagating RemoteAccessAPI permissions. 

Please help, that would be appreciated. Is this a permanent, or a temporary workaround? Syncing PBIX Onedrive, and Sharepoint files to a Power BI workspace is an appreciated functionality.

ISeeDeadKPIs
Regular Visitor

Its back again today. No issues for past 2 weeks. Had made some changes to the .pbix and was trying to refresh from the workspace and started getting the error not able to authenticate one drive credentials. Deleted the pbix to reupload and ofcourse its greyed out again. Has anyone got any solution to this ?

ISeeDeadKPIs_0-1680878387375.png

 

Wow.. not sure how this works but I think its something to do with getting signed in on the office portal. 
Logged in through firefox and confirmed the code through authenticator app and saw the options on Firefox. Then checked back on Edge - its available. 😥 No idea whats happening here.

This worked for me as well. Had to sign in to portal.azure.com with the same account i was using for PBI. Then re-opened the PBI TAB and it started working. 

CTrela
Frequent Visitor

Hi All

 

See the update from the logged issue from @Ian_Altis 
OneDrive/ Sharepoint upload greyed out and not wor... - Microsoft Power BI Community

-------------------------------------------------------------------------------------------------------

Hi @Ian_Altis ,

 

After our investigation First of all, this issue is not related to Power BI license or SharePoint license.
Secondly, it cannot be fixed on the Power BI side.

The way you can fix this is by ADDING the UseRemoteAPIs base permission to the Limited Access role definition at the site collection root web level.

The current user does not have the UseRemoteAPIs permission - Microsoft Community Hub

 

For propagating RemoteAccessAPI permissions :

  1. Select file, go to info pane, and click the Add person icon to go into grant access mode.
  2. Find the group to grant access to, deselect Notify, and click Grant Access button.
  3. This will share the file, ensure the Web level Limited Access group exists and has Web-Only Limited Access on the web, ensure the List level Limited Access group exists and has Limited Access on the specific list, and finally add the selected group to both of these system groups.
  4. The file can then be removed, and the limited access permissions will be retained on the web an list.

 

You need to do this on the Sharepoint 365 side.

If there are additional follow-up questions, please contact the SharePoint support team for further assistance.

 

Best regards.
Community Support Team_ Caitlyn

Ian_Altis
Advocate III
Advocate III

ISeeDeadKPIs
Regular Visitor

Well it works with PRO for me. The same PRO account that is a service account, Offshore team is not able to upload. 
Its random though. Days we would see it and some days it shows disabled.

Jay0403
Frequent Visitor

I have verified with a free Power BI user , the option is available. it does not have anything to with Power BI License or 365 license i think. 

Jay0403
Frequent Visitor

Looks to be same issue for some users in my organisation too. has something changed possibly after an update ?

Seems inconsistent, works in some orgs but not others, works for PPU but not all the time.  Not sure what the common denominator is.

Ian_Altis
Advocate III
Advocate III

I too am seeing this issue with a client.  They are a large organisation and have SharePoint, Teams and a Power BI Pro licences.  Very interested in hearing if there is a fix for this or a setting somewhere.

ISeeDeadKPIs
Regular Visitor

Hello, 


Am seeing the same issue. Pls keep us posted. 
I've another PPU account and 've uploaded the .pbix from there. Then through the PRO account which is giving the same issue as yours am taking over the ownership of the dataset. Still need to check if any issues with end users.

Interesting.  So am I right in saying it works with one PPU account but not another and not with a Pro account?

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.