Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
danextian
Super User
Super User

Unable to set data source credentials to public webpages

Hello,

 

This was never the case before. This used to be very straightforward. I would just go the data source credentials and set it to anonymous but now the data source credentials is grayed out and it is kind of asking me to setup a gateway connection for a cloud source. I used Web.Contents and relative path so there's no issue with the source being a dynamic one.

danextian_0-1719296315303.png

 










Did I answer your question? Mark my post as a solution!


Proud to be a Super User!









"Tell me and I’ll forget; show me and I may remember; involve me and I’ll understand."
Need Power BI consultation, get in touch with me on LinkedIn or hire me on UpWork.
Learn with me on YouTube @DAXJutsu or follow my page on Facebook @DAXJutsuPBI.
3 REPLIES 3
v-yaningy-msft
Community Support
Community Support

Hi, @danextian 

Thanks for @tez147 reply. You can configure a personal gateway to solve the problem.

vyaningymsft_2-1719818194156.pngvyaningymsft_0-1719818158877.png



Best Regards,
Yang

Community Support Team

 

If there is any post helps, then please consider Accept it as the solution to help the other members find it more quickly.
If I misunderstand your needs or you still have problems on it, please feel free to let us know.
Thanks a lot!

How to get your questions answered quickly --  How to provide sample data in the Power BI Forum

 

tez147
Regular Visitor

Hi @danextian 

When you select 'Web' connector to connect to public data, Power Query creates function 'Web.BrowserContents'("URL"). You can check this in advance editor in the Power Query.

We need to modify this function to 'Web.Contents'("URL"), refresh the report and publish it into the Power BI service. Remember to delete existing symantic model from Service before publishing the new one. 

Now it will say that "You don't need a gateway... and you can configure connection under the "Data Source Credentials". You can also set "anonymous" as authentication type. 

tez147_0-1719305508202.png

Please mark it as a solution if it has solved your issue.

 

Regards,

Tez147

 

Hi @tez147

 

That option is grayed out as shown in the screenshot.










Did I answer your question? Mark my post as a solution!


Proud to be a Super User!









"Tell me and I’ll forget; show me and I may remember; involve me and I’ll understand."
Need Power BI consultation, get in touch with me on LinkedIn or hire me on UpWork.
Learn with me on YouTube @DAXJutsu or follow my page on Facebook @DAXJutsuPBI.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.