Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
brft
Frequent Visitor

Unable to save datamart - DmsPbiServiceUserException

I have started getting an error on my datamart: Unable to sync the datamart with the automatically generated dataset.  Some reports may not be updated.  To try to repair this, select Transform data and then select Save.

 

When I try to to do the above, it generally proceeds through the loading data phase, then throws an error during the "Wrapping things up" phase of the type DmsPbiServiceUserException.  The full error is below.  The issue seemed to occur around the time of updating ownership of the datamart.

 

One other post PowerBI Datamart Error Message - Microsoft Fabric Community seemed to reference a "phantom" dataverse connection in the manage connection screen--I also have a dataverse connection here which is not being used.  Deleting or keeping it seems to make no difference.  It would be great if I could get this DM back up and running--would be nice to to have to recreate the entire thing as seems to be the go-to suggestion in other threads.

 

Activity ID: 92deaf0a-7666-8375-1c0a-b748b4cecc6c
Request ID: 1332af23-2537-4c37-8922-d0269f423f85
Status code: 500
Error Code: DmsPbiServiceUserException
Batch ID: 51dee642-34ba-4906-bb6e-fee3c6dfb66e@aa252125-69e3-440e-9a86-fe5f401a3d7a$2023-11-06T15:56:05.8614165Z@3be0cde6-9ac9-410a-94a8-50c151fb5128 

 

  • ErrorMessage{"error":{"code":"ExternalServiceUserFailed","pbi.error":{"code":"ExternalServiceUserFailed","parameters":{},"details":[{"code":"ModelingServiceError_Reason","detail":{"type":1,"value":"Error in ModelingSession creator connection to AnalysisServices"}},{"code":"ModelingServiceError_Location","detail":{"type":1,"value":"Connection to AnalysisServices"}},{"code":"ModelingServiceError_ExceptionType","detail":{"type":1,"value":"ModelingASOperationException"}},{"code":"ModelingServiceError_Message","detail":{"type":1,"value":"The database was not found in Power BI. Please check if it was deleted, or if you do not have permission to access it. Redeploying the database may also succeed, if the database can be recreated.\r\n"}}],"exceptionCulprit":1}}}
  • HttpStatusCode400
1 ACCEPTED SOLUTION
brft
Frequent Visitor

Correct--I did verify that I still have access to the source databases, and nothing has changed there. The error message does suggest redeploying, but I don't know what that means in the context of a datamart.  In the end, I copied all of the queries (actually quite fast, since you can ctrl-c/ctrl-v 40 queries together) into a new datamart, and I have not had issues since.

 

I have to blame the issue on trying to change the owner of the datamart--trying to take it over as I would a dataflow.  I will not try that again for the forseable future 🙂

View solution in original post

5 REPLIES 5
MatPS
Frequent Visitor

I know the error messages are misleading but I think you've misunderstood brft's request Scott, he's referring to a PBI Data Mart within Power BI not an external database / analytics services platform. I know as we've been having similar issues and are trying to work through them with MS Support. If you have anything to add based on this clarification, please let us know. If we manage to get to the bottom of it with MS Support, I'll share the resolution on here.

brft
Frequent Visitor

Correct--I did verify that I still have access to the source databases, and nothing has changed there. The error message does suggest redeploying, but I don't know what that means in the context of a datamart.  In the end, I copied all of the queries (actually quite fast, since you can ctrl-c/ctrl-v 40 queries together) into a new datamart, and I have not had issues since.

 

I have to blame the issue on trying to change the owner of the datamart--trying to take it over as I would a dataflow.  I will not try that again for the forseable future 🙂

MatPS
Frequent Visitor

I raised this particular bug with Microsoft Support on the 2nd Nov 2023 via the Support Portal, I was told it was officially recognised as an issue with the Power BI Service yesterday and the ETA for a fix is the second week of December (I'm hoping 2023!) so until that point I would suggest backing up any Measures and Advanced Queries you create directly in the PBI Service in a separate text file if you use PBI Data Marts just in case as the only current solution (if you'd call it that) may be to recreate the Data Mart from scratch!

 

If you opt for recreating the data mart, a big problem we had was how to connect the current PBI Reports to the new Data Mart created; this was done by downloading the PBI Reports with online connection, unzipping the PBIX file, changing the Connections file to point to the new Data Mart name and link (which can be taken from a different PBIX file connected to the new Data Mart at a push) and then rezipping them to follow the same structure and renaming them back to a PBIX - not ideal but could save hours of report rework. I'll update this comment if I find out more or a better way to do this and please keep a backup before trying this.

Thank you for sharing this, I have been having issues related to this bug. Messages like: "Unable to sync the datamart with the automatically generated dataset", or simply just missing tables/sources from the Explorer>Tables. Hopefully, this will be fixed by mid-December. Datamarts are an awesome feature, however, this particular issue might delay the adoption in our company.

v-tianyich-msft
Community Support
Community Support

Hi @brft ,

 

Based on the error message you've shared, it seems like there's an issue with the connection to Analysis Services. The error message suggests that the database was not found in Power BI, which could be due to it being deleted, lack of access permissions, or a need for redeployment.

Here are some steps you can take to troubleshoot this issue:

1. Check if the database exists in Power BI: Make sure the database you're trying to connect to exists and is accessible in Power BI.

2. Check your permissions: Ensure you have the necessary permissions to access the database. If you're unsure, you may need to contact your system administrator.

3. Redeploy the database: If the database does exist and you have the necessary permissions, try redeploying the database.

4.This also seems like it could be a temporary issue, please try it when it's not busy or clear cache

 

Best regards,
Community Support Team_ Scott Chang

 

If this post helps then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors
Top Kudoed Authors