Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Anonymous
Not applicable

The key didn't match any rows in the table

Hi community,

 

I have a very strange error "The key didn't match any rows in the table" when refreshing a dataset in the PowerBI webservice. The dataset refresh works fine when I do it in PowerBI Desktop.

 

I have seen similar questions where the solution was that an excel worksheet in the source was renamed. However, my only sources are dataflows and they do all work fine as well. 

 

Any ideas where I could look for an error?

 

Thanks

Martin

1 ACCEPTED SOLUTION
Anonymous
Not applicable

This is what I received from MS and it solved the problem for me

 

As informed earlier we have reached out to our Product team and got an update form them stating that the fix for the issue you are facing would be in next 2 -3 weeks. Workaround ========================================

The workaround is to turn off the SameSite settings in the browser. Go to chrome://flags or edge://flags and search for SameSite, disable the 2 (edge) or 3 (chrome) features that show up. Restart and it will work. Further we request you to try the above workaround and please let us know if you are still facing any issues. We apologies for the inconvenience caused. I look forward to hearing from you soon!

View solution in original post

39 REPLIES 39

I just started having this issue. Does anyone have a solution?

Anonymous
Not applicable

So I was on the phone off and on with PBI Support for several hours last night and they had made great progress resolving the issue. I know they were successfully able to debug several of the issues my datasets were having but I was still having issues with few. Ultimately I just manually triggered refreshes on the ones I having issues with and they refreshed successfully so it may be resolved.

 

One item they are still looking into is if it relates to the version of the Data Gateway. I don't understand that relationship to the issue but an avenue they are also looking at. I will update again when I hear from Support this morning.

@Anonymous  Sounds like you've made more progess than me - so far I've been advised to update the gateway (the dataflow doesn't use one as it's connecting to Azure SQL DB, plus the dataflow itself refreshes fine anyway) and update Power BI Desktop (we already have the latest version and it all refreshes fine through Power BI Desktop anway). Do you mind sharing your case number so I am able to advise Microsoft support that our cases may be similar?

 

I've noticed that problem datasets in my own "My Workspace" seem to refresh ok today (they didn't yesterday), but identical ones published to our premium workspaces do not. Are your datasets on a premium workspace?

Still broken on my end. How's it going for you all?

NickSter
Advocate I
Advocate I

I have exactly the same problem. Datflow is refreshing fine, but the dataset that uses the dataflow gives this error on refresh. I will also contact support about this. For the time being i am refreshing it manualy through PBI desktop and re-publishing it.
Anonymous
Not applicable

Just got off a Teams meeting with Support and they have the debugging team working to find the root cause of the issue. They recommended for an immediate solution to just not use Dataflows for ones that are erroring.

Anonymous
Not applicable

It seems that the debugging team has found and resolved the error. For me at least, the dataset refreshes work again

Anonymous
Not applicable

 Ok, sorry. It refreshed once and now we are back to the original problem...

Great to hear @Anonymous !

 

Do you happen to have any "Navigation" steps in your Dataflow that is creating the Dataset? I read in another thread, that removing this step will solve the issue, but if I did that it would no longer allow my REST API to retrieve to properly create a table within the entity...

Anonymous
Not applicable

We are having the same issue as well. Started a few days ago (2/10/20), only an issue for datasets that are on the web. Refreshes work on Desktop.

Has anyone contacted PowerBI support yet? Last time I had this issue, they were unable to help me and asked me to rebuild my dataflow entirely....

Anonymous
Not applicable

I am having this issue as well.. Using dataflows as the data source in the dataset and the error is happening when the dataset is refreshing in the service. It refreshes fine when I have the PBI Desktop file open and manually refresh, but errors when refreshing online. 

 

Below are the message received for one of the datasets.

 

Something went wrong
There was an error when processing the data in the dataset.
Please try again later or contact support. If you contact support, please provide these details.
Message: The key didn't match any rows in the table. Table: INVTRANS_NF.
Cluster URI: WABI-US-NORTH-CENTRAL-redirect.analysis.windows.net
Activity ID: d446c382-17eb-4d15-800b-ac707fe2a260
Request ID: 7a39b30d-1ee9-33b5-08fa-fe42b73199f6
Time: 2020-02-12 03:13:48Z

I have raised a support ticket with Microsoft. If I get any useful information I will report it here but I would encourage anybody else reading this who is experiencing the problem to raise it with support as well.

Same issue here today!

Data source error:The key didn't match any rows in the table The exception was raised by the IDbCommand interface. Table: Time Cards.
Cluster URI:WABI-CANADA-CENTRAL-redirect.analysis.windows.net
Alex_Rajkov
Advocate III
Advocate III

I have this, too. Since yesterday (while refreshing dataflows).

Microsoft support aknowledged it is a bug.

The support page should state that, but isn't...

@Alex_RajkovTo clarify, are you experiencing the error when refreshing a dataflow or when refreshing a dataset that is sourced from a dataflow?

refreshing a dataflow

@Alex_RajkovOK, slightly different to myself and the original poster then - my dataflows are continuing to refresh ok, it is just refreshing datasets sourced from one of them through Power BI Web that results in the error.

Anonymous
Not applicable

I am having the exact same issue, same circumstances, today.

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Power BI Header Change

Power BI Header Update

Read about the exciting updates for the Power BI forum.

Top Solution Authors
Top Kudoed Authors