Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Quinnie2017
Helper II
Helper II

The gateway is not running on your computer

Hi Everyone,

 

Problem: On-premise data gateway (personal mode) is throwing the following error:

Quinnie2017_0-1613776996014.png

 

Background: First installed this on 2/17/21 and connected successfully with scheduled refreshes on 2/18/21.  Now today 2/19/21 I am no longer connected to the personal gateway.

 

Here are the export logs.

 

Desired Outcome: Reconnect to gateway.

 

Can anyone help?

 

1 ACCEPTED SOLUTION
lbendlin
Super User
Super User

No, it's only a service if you installed the Enterprise Gateway version. Personal Gateway version runs as an application. 

 

Maybe uninstall and reinstall your personal gateway?

View solution in original post

14 REPLIES 14
Tineicesa
Regular Visitor

Hello. 
I have tried the solutions mentioned in the thread, however that has not resolved. Instead, now I am unable to reinstall the gateway. Any suggestions?

jomet
New Member

jomet_0-1663308640586.png

Check for this service if it is running. this solves the issue. If not reinstall the gateway.

CarelK
Frequent Visitor

This solved it for me. Thanks for the tip!

lbendlin
Super User
Super User

No, it's only a service if you installed the Enterprise Gateway version. Personal Gateway version runs as an application. 

 

Maybe uninstall and reinstall your personal gateway?

Yes, ultimately I unistalled and reinstalled the personal gateway this morning and it is up an running again.  Fingers crossed it continues to work.  Thanks for your help.

lbendlin
Super User
Super User

My apologies, I shoud have asked if you are using Personal mode or Enterprise mode?

On-premises data gateway should display in services, right?  I don't see it - which is confusing to me since the app is running?

Quinnie2017_0-1614009378033.png

 

Quinnie2017_1-1614009409418.png

 

 

Personal

lbendlin
Super User
Super User

What do you mean by "app"? I asked if the service is running. Please check the Windows services.

The application is running (meaning visually i can see it) but when I search for it in services it is not found...

Thanks for your patience, as you can gather I am a novice on this gateway stuff.

lbendlin
Super User
Super User

i didn't ask if it was running on 2/18, I asked if it is running now 🙂 

Yes and no.  Yes, app is running but no I still have same screenshot error.

lbendlin
Super User
Super User

Can you confirm that the gateway service is running on your PC?

It was running on 2/18 but on 2/19 I received the screenshot in the original al post on my pc.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.