Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Anonymous
Not applicable

Table Column empty on web, present in Desktop

I have a Report that contains a column called "Estimated Go Live Date". It is pulled from a SQL Server and used in a report.

The column contains data when I view it in Power BI Desktop. When I publish the column contains data too. (Like expected).

However it suddenly loses all contents. The rest of the report based on data from the same database is present and OK, only this one specific column loses it contents.

 

This seems very weird to me. There are no calculations, formatting or similar. There is nothing special about that column, except that the contents dissapears on the web report. (I have sveral other reports based on data from the same SQL Server and even the same database which works perfectly. )

 

Any ideas?

5 REPLIES 5
guibenassi
Advocate II
Advocate II

I have the same problem with two of my reports.

There is some relation with measures with boolean expressions but I can not identified the real problem.

Try to delete any measure in the report, eventhough it is not in the table or showing in the report and upload again.

Should fix, but you can not use this kind of calculations wich makes the Power Bi much more poor.

I have already open a service task on Microsoft but the attendee can´t help me.

I really expect that Microsoft fix this issue.

Best

v-shex-msft
Community Support
Community Support

HI @Anonymous,

 

If you create a new report with same datasource, can you import records with missing value field? 

In addition, did you apply any updates or setting s on your datasource side?

 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.
Anonymous
Not applicable

Thanks for taking the time.

 

The datasource is just fine. I can reload it in Desktop, and the column in question shows up.

If i publish it the column is there for some of the tabs in the report but not in others. No error messages during publish or after.

 

The dataset is set up to reload through on-premise data gateway and that works fine as well, with the exception of that one column.

 

 

Hi @Anonymous,

 

Can you please open a support ticket for better support? I can't find cause of this issue from your description and there is no error message displayed.

Power bi Support

submit a support ticketsubmit a support ticket

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.
Anonymous
Not applicable

I have opened a support case and they are scratching their heads over this...

PBIX files transferred too.

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors
Top Kudoed Authors