Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Frequent Visitor

'Something went wrong' when disconnect my workspace from git integration



My git integraton got stuck throwing error 'Something went wrong'. I am tring to disconnect the git integration and switch branches. It still gave the error :



I waited and tried and it has been working like this for half day. Can anyone provide advise?




Regular Visitor

I end up raising a Microsoft support ticket via the PowerBI platform. After a couple of days, it stopped sync'ing and allowed me to disconnect/switch branches. 

Helper I
Helper I

im also having this issue, has anyone found a resolution to it?

Regular Visitor

Does anyone has a solution to this, I have the same issue too.


The error message is not exactly meaningful:


Cluster URI

Activity ID 62beac1d-463e-4eee-b8bc-0df51818c141

Request ID e588b346-1ca8-db75-0f3d-433909689a66

Time Wed Apr 03 2024 08:54:27 GMT+0100 (British Summer Time)

Helper I
Helper I

We are experiencing the same issue. Two of us on different PC's/browsers have tried with the same results. We just get the same vague error message that you saw.

Any other ideas on how to get past this and force it to disconnect?

Community Support
Community Support

Hi @cailingjie0405 ,

Please have a try.

Check the compatibility of the plugin with your Jira administrator and update the plugin if necessary.
Check the connection with the development tool and try reintegrating the development tool.
Try clearing your browser cache and cookies, then restarting your browser


Please learn more about git integation:  Git integration process - Microsoft Fabric | Microsoft Learn



How to Get Your Question Answered Quickly 


If it does not help, please provide more details with the error.


Best Regards
Community Support Team _ Rongtie

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.






I have checked the items as you proposed. I even try to use another PC to do the same process. Unfortunately, it still have the same error.
I was able to connect to Azure DevOps before. However, there's error happening and the branch has been deleted.


It asked me to disconnect the branch. However, when I try to disconnect. It stuck with 'something went wrong'



Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.


Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.