Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
JonPBNES
Helper I
Helper I

Slicers: Workspace and App behaviours

We're just starting our org. roll-out of apps. On the whole it's been going well, but we're having a devil of a time with slicer behaviours. 

 

Specifically, I'm trying to work out what actions taken on a report in a workspace will change a slicer's default setting in the app (in this instance, simply moving the end date of a relative date slicer forward a few months). There does not appear to be a consistent way of reflecting this. I currently have a state where some reports in the workspace show one date on the slicer, but a different one on the app and others are the same. I have tried refreshing the app multiple times. 

 

I appreciate there is a good amount of documentation on how to keep slicers 'current' from a desktop end; which is on the backlog but it's a time-consuming process and we need to ship on Friday. 

 

Any advice on what 'normal' behaviour looks like in this environment would be welcomed. 

1 ACCEPTED SOLUTION
v-lionel-msft
Community Support
Community Support

Hi @JonPBNES ,

 

The slicer in WorkSpaace:

a2.PNG

The slicer in APP:

a3.PNG

When I published the APP, I returned to the workspace and changed the value of the slicer, then updated the APP, but I fond that the value of the slicer in the APP has not been updated.

 

Here 's a method to solve the problem after you changing the value of the slicer in your WorkSpace:

First, click "Edit report" button.

a4.PNG

Second, click "Save" button.

a5.PNG

Third, click "Update app".

(In other words, you must save the changes to the slicer before you can update it to the app.)

 

Best regards,
Lionel Chen

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

View solution in original post

5 REPLIES 5
v-lionel-msft
Community Support
Community Support

Hi @JonPBNES ,

 

The slicer in WorkSpaace:

a2.PNG

The slicer in APP:

a3.PNG

When I published the APP, I returned to the workspace and changed the value of the slicer, then updated the APP, but I fond that the value of the slicer in the APP has not been updated.

 

Here 's a method to solve the problem after you changing the value of the slicer in your WorkSpace:

First, click "Edit report" button.

a4.PNG

Second, click "Save" button.

a5.PNG

Third, click "Update app".

(In other words, you must save the changes to the slicer before you can update it to the app.)

 

Best regards,
Lionel Chen

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Thank you. That works as a fix, but it's not very sustainable as it requires a manual action to refresh the default slicer behaviour (this is required on a large number of reports and we're trying to take away the requirement for analyst involvement in period refreshes).

 

I think we may need to go back to the calendar tables, craete relative date measures and set filters on these, to try to force some updates that way. 

GilbertQ
Super User
Super User

Hi there

From what it sounds like, is it not that people have changed the slicer from the default. If you had to click on the "Reset to Default" button what then happens?

One option is to not allow the Persistent Filters. This would mean it would not remember each users filters though.




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Had an issue where the slicer setting for a date field was different in the app versus workspace. Even after saving and publishing, the app would show the relative date slicer when the workspace had the between slicer. Hitting the reset but on the upper right made the app match the workspace values.

jhalverson_0-1683732898803.png

 Thanks @GilbertQ !

 

I don't think so. Or at least not intentionally. This was just me opening the app in a new tab. 

 

'reset to default' didn't make any difference. 

 

It seems to have reset over time; is there a delay in parsing between the workspace and the app sometimes? (Some reasonably large reports & about 20 users). 

 

Either that or Chrome/our setup does interesting things with its cache and slicers. 

Helpful resources

Announcements
Fabcon_Europe_Social_Bogo

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

Top Solution Authors