Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
nelsong20
Advocate II
Advocate II

Slicer visual broken in PBI Service

The standard PBI Slicer visual seems to be broken in PBI Service. 

I have several reports that work fine in PBI Desktop, but when published to PBI Service, many of the slicers show nothing in their dropdown list.

If I edit a report, select one of the defective slicers, click "Show Data" it shows me the correct list of data that should be on the slicer, but there is nothing in the dropdown list.

I have tried re-publishing the reports but this hasn't helped.

 

Is anyone else experiencing this?

 

1 ACCEPTED SOLUTION
nelsong20
Advocate II
Advocate II

UPDATE on this ..... All seems OK now!

 

I thought to reboot my computer. In the process of rebooting, Windows performed a Cumulative update to W10 1803.

Now the slicers are working. 

Was it the WIndows update, or just the reboot? .... I have no idea.

 

View solution in original post

3 REPLIES 3
LukeWalker
Advocate IV
Advocate IV

 

Getting this error as well. On the left is the display in PBI Desktop and on the right is immediately after uploading to the service. 

 

Good.JPGBad.JPG

nelsong20
Advocate II
Advocate II

UPDATE on this ..... All seems OK now!

 

I thought to reboot my computer. In the process of rebooting, Windows performed a Cumulative update to W10 1803.

Now the slicers are working. 

Was it the WIndows update, or just the reboot? .... I have no idea.

 

I have this exact same issue, but it's still unresolved using this random fix.

 

Symptoms:

  • Report works perfectly in Power BI Desktop (My normal PC is W10 1511)
  • Deploy to PBI Service on Office 365, and it works exactly the same as Power BI Desktop
  • After a data refresh within PBI service, slicers do not work - most will display only one option "(Blank)"

My PC cannot be upgraded past 1511, so in despration I have installed a W10 VM and updated to 1803, transferred the pbix over to it, and redeployed it - however this still doesn't make any difference.

 

Net effect is that it is impossible to schedule data refresh on the PBI service, as it will break all of the slicers, which otherwise work perfectly provided that the PBI service does not do a data refresh.

 

I have systematically deleted almost every single object in the report (translation, query source, query, report tab, etc.) until the issue seemed to resolve itself - isolating it down to what was seemingly a single translation - however after I went back and removed that translation from the proper report, it didn't fix it.  I can only conclude that there is a bug in the PBI service's data refresh that does not exist in the PBI desktop - which is extremely frustrating.

 

@nelsong20does this sound like the same issue?  Is there anything else you can think of that could possibly be the resolution?

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.