Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
grnelson39
Microsoft Employee
Microsoft Employee

Search slicer not showing results after typing in search terms

I have a dropdown slicer with search bar enabled.  There are a lot of possible values (100K+) which is why I include the  search option.  However, when typing a search term, the expected values do not show as options (unless they were already visible in the top N options when opening the drop down).  Instead, I can type my search terms, click out of the drop down, and then click back into the drop down and the expected results will show up.  This only started happening recently within the past few days.  Before that the search worked as expected -> type in search terms and the drop down would automatically update with results according to search terms.  Any tips on how I can fix?  Is this an issue with the service?

1 ACCEPTED SOLUTION
v-jtian-msft
Community Support
Community Support

Hi,@grnelson39 .Hello,@christinepayton and @AnalyticPulse .
Thank you very much for your help with this issue.
You are very enthusiastic, and I'm very happy about that.I noticed that other users were having similar issues, so I tested it in my own environment as well.

vjtianmsft_0-1716196316663.png

According to my tests, this issue should be regional.

It's working fine on the service I'm testing.
Please check with other colleagues in the same tenant as you if they are experiencing similar problems.
Do you still have the problem? If you still have the problem, please do not hesitate to contact us!

I hope my suggestions give you good ideas, if you have any more questions, please clarify in a follow-up reply.

Best Regards,

Carson Jian,

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

View solution in original post

7 REPLIES 7
v-jtian-msft
Community Support
Community Support

Hi,@grnelson39 .Hello,@christinepayton and @AnalyticPulse .
Thank you very much for your help with this issue.
You are very enthusiastic, and I'm very happy about that.I noticed that other users were having similar issues, so I tested it in my own environment as well.

vjtianmsft_0-1716196316663.png

According to my tests, this issue should be regional.

It's working fine on the service I'm testing.
Please check with other colleagues in the same tenant as you if they are experiencing similar problems.
Do you still have the problem? If you still have the problem, please do not hesitate to contact us!

I hope my suggestions give you good ideas, if you have any more questions, please clarify in a follow-up reply.

Best Regards,

Carson Jian,

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

grnelson39
Microsoft Employee
Microsoft Employee

Here is another ticket with the same issue (posted 7 hours ago): Issue with slicer search in PBI service - Microsoft Fabric Community

AnalyticPulse
Impactful Individual
Impactful Individual

hi,

i suggest you compare the current version of your file with the older version if you have older version available. most of the time we are able to differentiate the changes in two versions. or there may be a change in source data or the configuration in search slicer. 

try to create the new slicer with same configuration and see if it works.
to debus the issue use your feild values in table visual to see if the values are being filtered out and hence not appearing on the slicer. also try to create a slicer on different page and see if its gettign the serched values, if you are able to see the results then there might be some filter on your page that are preventing the values from showing in result.

My blog:
https://analyticpulse.blogspot.com/2024/03/superstore-sales-2022-vs-2023-year-on.html
https://analyticpulse.blogspot.com/
https://analyticpulse.blogspot.com/2024/04/case-study-powerbi-dashboard-developer.html
https://analyticpulse.blogspot.com/2024/05/what-if-sun-disappeared.html

See my Pins :
https://pin.it/5aoqgZUft
https://in.pinterest.com/AnalyticPulse/



So this does seem like a bug (not a configuration issue).  When I'm editing the report in PowerBI desktop as PBIX, the search works as expected.  But if I publish and use on the service, i get the issue described above.  Also, as described, the search does work if I enter search terms, click out, and then click back in.  So there does seem to be a bug.

i had couple fo search slicers in my report and i haven't faces such issue hence I am inclined to feel that this is not a powerbi bug. but i will check in temporary report what you are suggesting. 

 

I don't think it's affecting all tenants (yet) - it's happening for me in one tenant and not in another, but it is reproducible in the tenant that it's happening in. 

Thanks for the info @christinepayton . 

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.