Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
PowerBIWhat
Helper I
Helper I

Scorecard Visual - stop numbers rounding to K or M

I've built a scorecard visual which has a metric where the value is currency £. I want the value to display as £2,200 but it rounds the number to appear as 2.2k.

 

I can't see any way of changing it. Has anybody looked at this before?

6 REPLIES 6
jmaher
New Member

I found the following solution to prevent the rounding of numbers when using a card graphic. 
1 - Click on the card graphic
2 - Click on Format Your Visual
3 - Click on the Visual Tab
4 - Scroll down to the Callout value and click the drop down arrow to expand the options

5 - Set the decimal places to whatever you need them to be. 

jmaher_0-1684277431648.png

 

GabrielL
New Member

I have the same issue, I wish they would give us more control.

For example, I'm forced to format KPIs in this manner once they cross the 1K threshold:

Screenshot 2023-01-24 090706.png

It is unnecessarily confusing.

PowerBIWhat
Helper I
Helper I

Hi,

 

This isn't a PBI desktop feature. It is the Metrics tab which has just been released on the service. In desktop and on the PBI app the values are 2,200 but for some reason in the Metrics tab on the score card it shows as 2.2k. Odd.

 

 

Hi, thanks for clarifying. I've tested it out as well and I could not find a way to reflect commas. It appears the default setting is in thousands. However, you can add a currency symbol by clicking on the three dots in the bottom-right of the visual and selecting 'Edit Metric'

 

Afterwards, click into the area of the specific value (in your case where 2200 would be). There should be a pop-up window on top > change the data format to 'currency' and set the decimal places to 2 as shown below

ama209_0-1663251944999.png

 

Even though this doesn't completly solve the problem, I hope it helps!

 

Yep, that is the method i've gone for. Not perfect and don't think I could release to the business with that format.

 

Thanks for the help. Hopefully Microsoft can make the small change.

ama209
Frequent Visitor

Hi PowerBIWhat, have you tried the following in PowerBI Desktop?

For adding the £ symbol:

-- Go to 'Data' view > Select the column that the metric is pulling from >Under the 'Column Tools' tab (in the ribbon up top), click on the arrow beside the currency symbol (it might look like a '$' based on your region) > Select '£ English (United Kingdom)'. This will convert the values in the column to the £ currency. THEN make sure to select the ',' icon which is in the 'formatting' section of the ribbon. This ensures that commas will be included when values reach 1,000 or 1,000,000 and so on.

 

For displaying £2,200 on the card

-- Go back to the 'Report' view > Select the scorecard visual > In the 'Visualizations' pane (typically on the right of your screen) > Click on the 'Format your visual' icon (looks like a column chart with a paint brush on it) > Select 'callout value'  > Change 'Display units' to 'None'.

 

Let me know how it goes and please like if you found this helpeful.

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors