cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Harry_007
Regular Visitor

Scheduled refresh has been disabled.

Data source error: Scheduled refresh is disabled because at least one data source is missing credentials. To start the refresh again, go to this dataset's settings page and enter credentials for all data sources. Then reactivate the scheduled refresh.
Cluster URI: WABI-US-NORTH-CENTRAL-B-redirect.analysis.windows.net
Activity ID: cde2c06c-2c00-4903-9d41-ef7d16ab89f1
Request ID: 2e121a6c-f23c-8a1d-5633-b8446e86b349
Time: 2022-01-18 07:36:00Z

 

Since I am the owner of this dashboard I'm unable to edit the credentials and unable to reactivate the scheduled refresh 

can someone help me 

 

I have connected the power bi service from SharePoint 

2 ACCEPTED SOLUTIONS
ibarrau
Super User
Super User

Hi there. The dataset owner or a workspace admin (taking control of the dataset) can edit the credentials for the source.

They should get on the dataset configurations under "Data Source Credentials", then edit credentials. If you have a sharepoint connection configured directly to web, it should look like this but with a small icon of warning:

ibarrau_0-1642509879576.png

 

Introduce the correct credentials and run the refresh again.

I hope that helps,


If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Happy to help!

LaDataWeb Blog

View solution in original post

You might need to get the PBIX from the report to modify the source because the error is saying that it can't find the excel file in that path at sharepoint. The file could have been moved or deleted and now the path doesn't make sense for Power Bi. 

If you know where the file is in sharepoint, I would suggest editing the PBIX file to change the data source (url). You could move also move the file to the path in sharepoint that power bi is reading but it might not work.

I hope that helps,


If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Happy to help!

LaDataWeb Blog

View solution in original post

8 REPLIES 8
alr
New Member

Hi,

 

I am getting the same error "Scheduled Refresh has been disabled" and to edit credentials. What do I need to change the credentials to? I am a new Power BI user and am looking for a simplified answer please. Thank you

Angel22
Frequent Visitor

I have the same issue, Local power bi file (linked to excel file) sync via onedrove/shareporint uploaded to the power bi workspace. It says gateway connected to the datasource but get the error Data source errorScheduled refresh is disabled because at least one data source is missing credentials. Editing the credentials ends up in an infinite loop like descibed by rcarrol. Anyone has the solution to this?

ibarrau
Super User
Super User

Hi there. The dataset owner or a workspace admin (taking control of the dataset) can edit the credentials for the source.

They should get on the dataset configurations under "Data Source Credentials", then edit credentials. If you have a sharepoint connection configured directly to web, it should look like this but with a small icon of warning:

ibarrau_0-1642509879576.png

 

Introduce the correct credentials and run the refresh again.

I hope that helps,


If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Happy to help!

LaDataWeb Blog

Basically there are 3 steps to follow 

 

1) Check the gateway connection is enabled or not , If its not enabled then There will be a download option , Once its downloaded , You need to signin into the on-premises gateway personal mode , Then just setup a connection in that

PS: Use the same email id , which is used for power bi.

 

2) Enter the right credentials in the Data source credentials.

 

After all this , If its still disabled then you need to Drag down the option of gateway connection then pull down the schedule refresh option

 

 

All done , Do let me know if you still face any issues

Hi, Thanks for the response.

I have tried to edit the web credentials but it is not working it's showing the below error

 

error im gettingerror im getting

 

 

You might need to get the PBIX from the report to modify the source because the error is saying that it can't find the excel file in that path at sharepoint. The file could have been moved or deleted and now the path doesn't make sense for Power Bi. 

If you know where the file is in sharepoint, I would suggest editing the PBIX file to change the data source (url). You could move also move the file to the path in sharepoint that power bi is reading but it might not work.

I hope that helps,


If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Happy to help!

LaDataWeb Blog

Hi, I have the same problem. My screen looks like this:

SIH007_1_0-1663914380141.png

And I can't set the privacy level. I edited the credentials of one of my Excel files (on a server share, not Sharepoint) yesterday afternoon, now it is 8:30 a.m. and it still did not change the state showing.

Have you been able to find a resolution to this? Your situation seems very similar to mine (Nothing happens after I click "Sign in" other than the spinner icon animating indefinitely.).

Helpful resources

Announcements
PBI Sept Update Carousel

Power BI September 2023 Update

Take a look at the September 2023 Power BI update to learn more.

Learn Live

Learn Live: Event Series

Join Microsoft Reactor and learn from developers.

Dashboard in a day with date

Exclusive opportunity for Women!

Join us for a free, hands-on Microsoft workshop led by women trainers for women where you will learn how to build a Dashboard in a Day!

MPPC 2023 PBI Carousel

Power Platform Conference-Power BI and Fabric Sessions

Join us Oct 1 - 6 in Las Vegas for the Microsoft Power Platform Conference.

Top Solution Authors
Top Kudoed Authors