Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Helper I
Helper I

Scheduled refresh gives an error for table which is not included in report refresh



I have removed the check mark from "Include in report refresh" in PowerBI desktop for one of the tables in my report. (The reason for this is that it is based on web.source which has changed and I don't have time to fix it now.) When I refresh the report in Desktop, it works OK and does not attempt to refresh that data source. When I publish the report and try to schedule a refresh (or refresh it manually in the PowerBI Workspace) it gives an error about that table. So, to me it seems that it is not excluded from the report refresh.


Is this a bug?

Is there another workaround to disable one table's refresh?



Community Support
Community Support

HI @helenah,


Why don't you disable the load option? I'd like to suggest you turn off the refresh option and load option at same time, after finish these steps, current query weren't loaded/refreshes.(please ensure you haven't reference these queries at other tables)


>>When I publish the report and try to schedule a refresh (or refresh it manually in the PowerBI Workspace) it gives an error about that table.

In my opinion, even if you turn off the refresh option, power bi will at least load it once from datasource.(notice: power query not support cache history records)



Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.


>>Why don't you disable the load option?<<


That would effectively remove the query from the model. Doesn't sound like that is what the user wants. 


I agree that this is either POOR DESIGN by Microsoft, or a BUG. 


If I mark a query to NOT be refreshed, It means JUST THAT: Don't try to refresh it. Sholdn't matter if the context is the Desktop or the Service. 


The service NEEDS to be changed to honor this setting! Is there a User Voice item on this?


It's like putting up a STOP sign in your neighborhood and saying that if you're driving a pickup you don't need to stop!

Did I answer your question? If so, mark my post as a solution. Also consider helping someone else in the forums!

Proud to be a Super User!

Helpful resources

Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City


Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors