Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

New Member

Scheduled Refresh Succeeds but Data Won't Update

I have built a Power BI report that queries data from a SQL Server database at my organization. I've uploaded the report to Power BI online and set up a scheduled refresh with the help of our IT staff. Everything is showing as "green" and I get confirmation that the data refresh succeeds each time it's set to occur. There is no error message or other notification that the refresh failed. HOWEVER, the actual data in the report does not update to reflect the most current data in our SQL Server database. 


When I go into Power BI Desktop and hit the "Refresh" button on the report manually, the data DOES update and show correctly based on the current data in the SQL Server databse. 


Is there a way to fix this issue so that the scheduled refresh in Power BI will actually update based on the most current data in our database? 


@spinachbisque How quickly are you checking the report after the dataset has said it has refreshed? The Dataset, Report and dashboard are seperate objects and are not all immediately refreshed after the dataset. It is in order. If the dataset refreshes, it is likely it will be 10-15 before the report, and then the Dashboard. You can also initiate a refresh in the report after the dataset.

If you know, and or tried the above, then this sounds like a bug or issue that you should raise in a support ticket or the issues page.

Looking for more Power BI tips, tricks & tools? Check out the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG

View solution in original post




I've been pursuing this with the MS support team since it first became an issue for me in April and after numerous email exchanges and screensharing sessions, they don't appear to be any closer to providing a solution.


They believe that the problem is related to the data connectivity mode and specifically an issue with datasets suppossedly configured as DirectQuery remaining as an Import model behind the scenes.


I'd like to be able to provide more input but I'm becoming increasingly frustrated with the entire affair and the most recent telephone calls with the MS off-shore team have been incredibly discouraging.


I'll update this stream if there is further progress.

Not applicable

Thanks for the update on that @ims20180411kjb , really appreciate it.

I can fully understand your frustration, and I guess I can empathize to some extent with the MS devs, it might not be a simple fix. An official update from them however would be something at least, to let users know that their frustrations are not going unheard..

I look forward to your (hopefully positive) future updates, will stay tuned.

Thanks again 🙂

Not applicable

In my case, the server runnning the gateway stuff crashed.  I had to re-set iup the gateway stuff on a different box and it's been working as it should since then.  I don't trust it won't break again, but so far so good...

Not applicable

+1, same here.  Hoping someone has something on this some day soon.

Hi, the same here, seems to be a global problem

Not applicable

My Power BI Desktop version won't update either...


I can see the data clearly updates within the Data view and within any Query. But the report view will not reflect the changes. Funny enough... if I create a new report on a new tab. It will update accordingly - just anyhting already in the file will not update.

I recently experienced this same issue but think I found a solution.  After the scheduled refresh is complete I make sure to close out all open Chrome tabs and then go back into the workspace and hit refresh on the reports.  Now the refreshed data seems to be populating.  I did this about two hours after the auto refresh was complete.


Will test again tomorrow morning and report back.

Helper II
Helper II

It seems scheduled refresh is not being triggered

Frequent Visitor

Hi Everyone

Glad to see we are not the only ones facing the problem - thought it was something we did wrong.

We also need to refresh data in the desktop version in order to get the data in the web refreshed.


Please can we have some feedback on this issue as it is quite a time consuming process when dealing with a lot of reports that needs to be refreshed on a daily basis

Just to add, I noticed that publish to web is updated while the one in my workspace is not and I have to republish twice and do a manual refresh in my workspace. 



Not applicable

Did you find a solution to this problem? I'm having the same issue and cant figure out why it is happening

Hi, I'm also experiencing the same issue.


I have two reports in a workspace and their associated datasets both use the same gateway to two different databases in the same SQL Server instance.


The datasets for both reports indicate that they have refreshed at the scheduled time. However, whilst one report shows the refreshed data, the second report does not, even if I click the report refresh button.


Similarly, clicking the 'Refresh now' action within the Datasets list has no effect.


I have tried republishing the report, which works for that day but then fails to refresh the following day. I have deleted the reports and associated datasets and even deleted the Gateway but to date, none of these attempts have succeeded in resolving the issue.


Any input or advice would be appreciated.





Not applicable

Hi Karl,


I am experiencing the same issue trying to connect to two databases with one gateway.


Have tried a workaround using a view which doesn't fix anything - have you managed to solve the issue?



Not yet unfortunately Joshua. I'm still awaiting further contact from the support team who were attentive initially but now appear to have disappeared and are not replying to my emails.

Not applicable

This exact same problem is happening to me as well. It started around 5/1. I never get any refresh errors, but I don't see the most up-to-date data on my reports.


The only way to solve this has been to refresh from Power BI Desktop and reupload, which is very time consuming.

EXACTLY the same issue here.  The refresh history claims that the data was updated successfully again and again, yet the report does not show any recent data, even after a manual report refresh.  I have to open the report in the desktop app, refresh it and republish it to bring up to date data to the cloud report.  What is doing with all that beautiful data it's supposedly gathering for us is a mystery. 


Have you found the solution to this? I am facing the same problem.


Not applicable

I've semi solved the issue, by not doing any data manipulation in PowerBI at all - and only using one data source :S

We are experiencing the same problem - out of curiosity (as I saw some people mentioning above), does everyone kinda have the same situation happening here?


1. Multiple databases

2. Direct Query Datasets based on Views


Appears to be a pattern. The above is precisely what's up with our dataset.

Hi jonathanf,


I've opened a support call to deal with this and will keep you updated. However, at this point they seem to be stumped.





It's been a while but we'd appreciate an update on what came of this.

Helpful resources

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.


Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.


Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors