Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

Reply
ryanzimmerlee
Frequent Visitor

Required to 'Reset to Default' After Publishing to Workspace

Hello,

 

When publishing my Power BI reports to the web service and upon opening the report, I'm required to select "Reset to Default" every time, on every page, as the report level page filters and slicers are reseting to 'All' or without a set selection.  I expected the report page filters and timedata slicers I've set to be the "standard" upon loading this report and each page.

 

I've tried publishing with the new Persistent Filters option enabled and disabled, both within Power BI Desktop and the web service.  

 

I'm not using any preview features.  

 

I did not create the Workspace I'm publishing to, but I am and have been the sole publisher.  Is it possible there is a setting within the app workspace environment that is inhibiting what I believe I should be seeing?  

 

Thanks in advance.

Ryan

 

 

1 ACCEPTED SOLUTION

Hi @v-cherch-msft ,

 

Thanks for taking the time to look into my problem.  The report I've created is navigable through the use of buttons and bookmarks.  I failed to realize that the bookmarks were not updated to include the set filters on the report page.  Simply updating the bookmark to include those changes avoided any need to "reset to default".  

 

My own silly doing...

 

Thanks again.

Ryan

View solution in original post

17 REPLIES 17
Anonymous
Not applicable

I was having the same issue with my Slicers; they would default back to List versus Dropdown. Instead of creating a button that reads "Clear All Filters" I changed it to "Reset to Default" just as the Published version has already at the top right of the Dashboard. Now after I select Multiple Selections on the Slicer, I hit my "Reset to Default" button and all my Slicers return to "All" & Dropdown.

Anonymous
Not applicable

Hello,

My Question is regarding the Reset Button. I have used a reset Button with Bookmark feature in my power Bi Desktop.I published the report in a Workspace where the Reset button is working but the time i Pin the report to the live page ,the reset all button stopped working and i have to use the selection feature.

Please suggest.

 

Thanks in Advance.

Abhishek

Anonymous
Not applicable

We have this problem with one specific slicer changing it's default selection control choice from single selection to multiple whenever it is published -- the workaround (as per the pervious comments, selecting Reset to default on every page of the report) corrects the issue but is not a sufficient fix for our user profiles

 

I have not seen a fix published - is there one available yet?

v-cherch-msft
Employee
Employee

Hi @ryanzimmerlee 

Based on my test,i cannot reproduce the same issue.The report level filter would be the same after publishing it from desktop to app workspace(role publisher).The "Reset to Default"  would be grey.Please have a look at this article to check if it could help you.

1.png

Regards,

Community Support Team _ Cherie Chen
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

hi - this isn't fixed

Hi @v-cherch-msft ,

 

Thanks for taking the time to look into my problem.  The report I've created is navigable through the use of buttons and bookmarks.  I failed to realize that the bookmarks were not updated to include the set filters on the report page.  Simply updating the bookmark to include those changes avoided any need to "reset to default".  

 

My own silly doing...

 

Thanks again.

Ryan

Anonymous
Not applicable

I too just had this problem appear overnight. I did not make any changes to my pbix file. The problem simply appeared. The Reset to Default button appears every time I open the report on the service. I updated my bookmarks as indicated but that does not appear to solve the problem.

 

Any additional guideance is appreciated.

Anonymous
Not applicable

We have seen this issue suddenly appear over the last few days, we opened a support ticket -- waiting to hear back from Microsoft.

 

Jim

We have the same issue appear as of yesterday as well. As an admin, I have not made any changes and all the sudden, this issue occur. Following the forum, thank you all for sharing your solutions. 

Anonymous
Not applicable

Thank you. Please share any solutions they provide.

 

John

Anonymous
Not applicable

Team,

 

Response from support:

 

The Product team was made aware of this and has already developed a fix, which should be released with an update to the Service on Sunday, December 15. Until then, using the “Reset to default” workaround is the recommended action for viewing your reports.

Anonymous
Not applicable

hi - is there an update on this fix?  it isn't working for us

Anonymous
Not applicable

I never saw that the fix was included in an update but this no longer is a problem for us.

Anonymous
Not applicable

Hello,

 

Do you received the solution of this problem?
I have a similar problem. M Power BI report is now working fine, I have to click on ‘Reset to default’ or load the report twice to see the data.

And I have to custom visuals in my power bi file. the custom visuals are nos loaded initially, I need to click twice to see data.

Plase share when you have any update. Thank You and best regards.

 

No updates yet, just more and more users are being effected by this bug. 

It also happens to me but only to a specific report, the others seem fine so far...

Yes, just one of the reports that is effected by it for me as well. 

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

Top Solution Authors