Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
Mani008
Frequent Visitor

RLS - not working for users who had member permission to workspace earlier

I have created roles to setup Row level security on report in desktop and published it to service. I have added user security for that dataset in power BI service and RLS is not working for few users who had 'member' access in the past. It still thinks like they are having 'member' access. 

 

I have done the following : 

 

1. removed the 'member' access in workspace , republished/refreshed the report& dataset. Added that user only in RLS. However , she can still see everything . RLS not working for those users , for others its working as expected (P.S: others were not having 'member' access in the first place) 

 

Any ideas ? Is there anyway to refresh the security after changing the permissions to make it work immediately. 

 

 

2 ACCEPTED SOLUTIONS
v-cazheng-msft
Community Support
Community Support

Hi @Mani008,

 

To make RLS take effect for a user, you couldn’t give this user a workspace role more than Viewer. So firstly, please make sure this user is added at most Viewer and there isn’t any group that contains this user added to this workspace as Admin/Member/Contributor. Once you complete the operation, please refresh your browser page  and make sure the above setting is working.

 

After that, you could call this rest api to refresh users’ permissions to guarantee they’re fully updated.

Users - Refresh User Permissions - REST API (Power BI Power BI REST APIs) | Microsoft Docs

 

Then, ask the user to access this report again.

 

If there is any post helps, then please consider Accept it as the solution to help the other members find it more quickly. If I misunderstand your needs or you still have problems on it, please let me know. Thanks a lot!

 

Best Regards,

Community Support Team _ Caiyun

View solution in original post

@v-cazheng-msft  Thanks for the rest api link . It worked after I run it . 

 

View solution in original post

6 REPLIES 6
v-cazheng-msft
Community Support
Community Support

Hi @Mani008,

 

To make RLS take effect for a user, you couldn’t give this user a workspace role more than Viewer. So firstly, please make sure this user is added at most Viewer and there isn’t any group that contains this user added to this workspace as Admin/Member/Contributor. Once you complete the operation, please refresh your browser page  and make sure the above setting is working.

 

After that, you could call this rest api to refresh users’ permissions to guarantee they’re fully updated.

Users - Refresh User Permissions - REST API (Power BI Power BI REST APIs) | Microsoft Docs

 

Then, ask the user to access this report again.

 

If there is any post helps, then please consider Accept it as the solution to help the other members find it more quickly. If I misunderstand your needs or you still have problems on it, please let me know. Thanks a lot!

 

Best Regards,

Community Support Team _ Caiyun

Then whats the use of creating a workspace with access other than viewer . Why cant the RLS apply for the report ? It is very easy in Tableau , even user is admin or explorer , if user id RLS is applied they wont be able to see it , is there a similar functionality in Power bi ?

@v-cazheng-msft  Thanks for the rest api link . It worked after I run it . 

 

Mani008
Frequent Visitor

@Shahfaisal  Thanks for the response. 

I have tried that. No luck. 

I have removed the groups from the workspace and I am the only one having 'Admin' Access to this .  Only one group is added into RLS settings and she is a part of it. 

@Mani008 , Have you double checked your RLS role-logic? Try to test the role with another user in the group. If they are also able to see everything instead of what they should be seeing per the RLS layer, then the error might lie in the security role. 









Shahfaisal
Solution Sage
Solution Sage

Two things come to mind:

1. Can you check to make sure that she is not part of a group that has member access to the workspace?

2. Can you try to temporarily remove her access to the workspace completely and add her back (I understand that this may not be possible as it might cause access disruption)

Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors