Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
delish68
Frequent Visitor

RLS Not Working with "Intermediary" Model

Apologies if this is confusing...

I have a "core" semantic model called "Financial Model". It has RLS implemented within it. It works fine when tested within Power BI Desktop and also works with a very basic "RLS Test" report on the Power BI service. However, I have another report called "Expense Report" that is also built on top of the "Financial Model" model and RLS does not work within it.

 

My theory is that because "Expense Report" has some custom measures, when published, a new "intermediary" model called "Expense Report" is published alongside it and RLS is not being passed from the "Financial Model" model, up through to the "Expense Report" model, and ultimately to the "Expense Report" report. Hopefully the image below helps. 

 

delish68_1-1703609036174.png

 

Can this be fixed? In other words, can I have a report with custom measures, built on a model with RLS, and still have RLS passed through to my report?

 

1 ACCEPTED SOLUTION
delish68
Frequent Visitor

I got to the bottom of this. At some point, one of the developers enabled DirectQuery, which creates this "intermediary" semantic model. I don't think there's a way to remove that so we are copying and pasting everything from the original report to the new report.

View solution in original post

10 REPLIES 10
delish68
Frequent Visitor

I got to the bottom of this. At some point, one of the developers enabled DirectQuery, which creates this "intermediary" semantic model. I don't think there's a way to remove that so we are copying and pasting everything from the original report to the new report.

aj1973
Community Champion
Community Champion

Hi @delish68 

The RLS is only applied to its semantic model, it cannt be carried on to the semantic model that is built on top of it.

Regards
Amine Jerbi

If I answered your question, please mark this thread as accepted
and you can follow me on
My Website, LinkedIn and Facebook

There isn't a semantic model explicitly/intentionally being created on top of it. I'm only guessing that it's being created because the report has some custom columns or measures in it. The intention is for the report to sit directly on top of the semantic model with RLS. Is there a way to resolve this?

aj1973
Community Champion
Community Champion

You can build a new report with live connection to your dataset

aj1973_0-1703612678604.png

 

Regards
Amine Jerbi

If I answered your question, please mark this thread as accepted
and you can follow me on
My Website, LinkedIn and Facebook

That's exactly what we did. However, when we publish the report, we end up with an additional semantic model with the same name as the report (which points to the live Power BI dataset).

aj1973
Community Champion
Community Champion

Sorry, you need to create it in the service

aj1973_0-1703613331954.png

 

Regards
Amine Jerbi

If I answered your question, please mark this thread as accepted
and you can follow me on
My Website, LinkedIn and Facebook

It's a complex report that's already been created. Having to create it in the service seems like an odd requirement. I think the important question is, why is this additional semantic model (Expense Report model) being created when my report is built on the "Financial Model" model?

delish68_0-1703613670006.png

 

delish68_1-1703613720057.png

 

aj1973
Community Champion
Community Champion

Because you have created it when using Get Data in power bi desktop.

The main purpose for that action is when a developper creates a big Dataset or, Dataflows or Datamart to be reused by other users without editing the master one for security reasons.

Regards
Amine Jerbi

If I answered your question, please mark this thread as accepted
and you can follow me on
My Website, LinkedIn and Facebook

I have created other reports in Power BI desktop, based on the Financial Model (using Get Data), and it does not have the same behavior of creating an additional model when publishing.

aj1973
Community Champion
Community Champion

Not same behavior ! and after publishing you don't get a new Semantic model in the service !

Sorry but It seems weird.

Regards
Amine Jerbi

If I answered your question, please mark this thread as accepted
and you can follow me on
My Website, LinkedIn and Facebook

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

Top Solution Authors