Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Helper V
Helper V

Published Reports show wrong value after refresh of dataset on server



Something strange is happening and I cant figure out the issue.


I have a dataset with a datasources odatafeed. When i refresh this dataset in powerbi desktop, save it and publish, all goes well and reports published working fine.


However, when this dataset gets refreshed on the service (on a scheduled time), all data in the visuals used in the published reports is gone after the refresh is complete. So the visuals are still there, but without data, or data is missing.


The only way to get data back is to publish again from within power bi desktop


So i wanted to do a test: I deleted all tables in my dataset, except one (loaded from topdesk odatadeed), and deleted all columns of this table except one. This table/column only contains ids. There are over 60k records in there.


Now even when I publish this and refresh on the service after, the report shows wrong numbers;


Top is the count in powerbi desktop and below is count after a refresh on the service



Anyone an idea what is going on here?



Community Support
Community Support

Hi  @TechR21 ,

You can try to check the following points.

1. Every time you refresh a dataset in the power bi service, it is replaced with what is in the data source, if the data source may not have data, the old data will be cleared when you refresh and the result will be empty.

Or the low number of rows seen in the power bi service may be due to the low number of rows in the data source at the time of refresh

When you configure a time for scheduled refresh, there can be a delay of up to one hour before it begins. Make sure the Enterprise Gateway is running and you edit correct credentials. Then you can check if the refresh occurred times within a period in Refresh History. 

Data refresh in Power BI - Power BI | Microsoft Learn


2. If there is a Boolean data type in your dataset, it may cause this to happen. You can modify the Power BI filter to solve it,

Reports doesn’t show data in Power BI Web service after refresh – Issue with True/False values (c-sh...

After a scheduled refresh the report has no data - Page 2 - Microsoft Power BI Community


3. Whether the functions of Now() and Today() exist in your dax formula, the Today() function on the Power bi service returns today’s value according to the UTC() time zone, while the Today() function on the Power bi desktop shows the computer’s system time, so in Power bi service, your time zone and standard time are different, resulting in data not appearing.


4. Possibly related to the date:

Solved: Power BI Service - Data Missing after refresh - Microsoft Power BI Community


5. Is the gateway the latest version, if not, please upgrade to the latest version.

Update an on-premises data gateway | Microsoft Learn


This is the related document, you can view this content:

After a scheduled refresh the report has no data - Page 3 - Microsoft Power BI Community

Missing Data after Refresh in Service | Power BI Exchange (

Best Regards,

Liu Yang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.



i updated the post with a test I ran, with only one column but still after the refresh on the service it doesnt show correct count.

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.