Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
hvacdata
New Member

Problems with Gateway connection

Recently our gateway was accidentally removed during a MS tenant move. We have rebuilt the gateway, but now i keep getting "gateway not configured properly error" on the app and failed refreshes. I made and published a simple semantic model using only one odbc data source. 

hvacdata_0-1712675630091.png

I click the add to gateway, even though this source is used in up to a dozen other models. I go through to create the new connection but it gets rejected due to "Unable to create connection for following reason: duplicate connection name". I tested by giving it a different name, doing so allowed me to add it to the gateway. I was looking for guidance on possible reason that I cannot connect to the already existing connection that other models already use. Any help would be greatly appreciated. I am holding off on doing the uninstall and reinstall method until i have exhausted possible fixes. 

1 ACCEPTED SOLUTION
v-kongfanf-msft
Community Support
Community Support

Hi  @hvacdata ,

 

Thanks for the reply from @lbendlin , please allow me to provide another insight:

 

Semantic Model Dependencies: Since you mentioned that the ODBC data source is used in several other models, make sure that there are no dependencies or specific configurations in those models that could lock down connection names or require exclusive access. This may involve looking at the configurations of these models to make sure they are not causing problems
By the way, is another data source experiencing similar issues or is it isolated from this particular ODBC data source?

 

For more details, you can read below document about gateway's troubleshooting.

Troubleshoot gateways - Power BI | Microsoft Learn

 

Best Regards,
Adamk Kong

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
hvacdata
New Member

I got this figured out everyone thank you for the suggestions. Issue was with the individual data connections. When the move to the new MS Tenant occured evidently it lost all "users" attached to the connections. 

v-kongfanf-msft
Community Support
Community Support

Hi  @hvacdata ,

 

Thanks for the reply from @lbendlin , please allow me to provide another insight:

 

Semantic Model Dependencies: Since you mentioned that the ODBC data source is used in several other models, make sure that there are no dependencies or specific configurations in those models that could lock down connection names or require exclusive access. This may involve looking at the configurations of these models to make sure they are not causing problems
By the way, is another data source experiencing similar issues or is it isolated from this particular ODBC data source?

 

For more details, you can read below document about gateway's troubleshooting.

Troubleshoot gateways - Power BI | Microsoft Learn

 

Best Regards,
Adamk Kong

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

lbendlin
Super User
Super User

go to the ODBC-64 control panel on all gateway cluster members and clean up the connection names there. make sure the connections all test successfully.

 

Helpful resources

Announcements
LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors