Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
prathyoo
Helper III
Helper III

Premium Gen 2 - Reports stuck on Almost Done

We moved to the Premium Gen 2 preview last week and we have noticed that quite a few of our reports are now stuck in the "Almost Done" loop for at least 5 minutes. Subsequently, after the reports finally load, the performance seems to be fine until the next dataset refresh. We have noticed this only after moving to Premium Gen 2.

6 REPLIES 6
prathyoo
Helper III
Helper III

We had the same issue today with all the reports connected to one of our datasets. All the reports were stuck for nearly 20-25 minutes and then some of the reports started working but would take atleat 30 seconds to generate. The dataset was last refreshed 6 hours ago and to test we also did a manual refresh but that did not solve the issue.

 

We then switched off the Premium Gen 2 preview and immediately all the reports started working fine.

v-yangliu-msft
Community Support
Community Support

Hi  @prathyoo ,

 

Good, I suggest you observe for a few more days. If there is any problem, you can reply in time and give us feedback. If not, you can mark.

 

Best Regards,

Liu Yang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

v-yangliu-msft
Community Support
Community Support

Hi  @prathyoo ,

Have you restored to Premium Gen1 and whether this data refresh can run normally?

The refresh of Premium Gen2 is a background operation, and the refresh operation will be allocated to 24 hours. Now Premium Gen2 is currently in preview.

 

This is the related document, you can view this content:

https://docs.microsoft.com/en-us/power-bi/admin/service-premium-concepts

https://docs.microsoft.com/en-us/power-bi/admin/service-premium-gen2-what-is

 

Best Regards,

Liu Yang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thursday, 16th September is when we faced the issue of preformance. Since then our capacity has worked fine. We are still monitoring the Premium Gen 2 capacity to see if we hit performance issues again.

 

prathyoo_0-1632122621641.png

 

prathyoo
Helper III
Helper III

Ten minutes after the last update, the reports started waorking fine. Three hours later, all the reports are back to looping through "Almost Done". I plan to revert back from Premium Gen 2 preview to the earlier premium capacity to check if the issues disappear.

prathyoo
Helper III
Helper III

Currently, a 3 page report which used to load within 6 seconds (as per Usage metrics report), is looping for the past 6 minutes in "Almost Done" loop. We also got an alert that we have hit the capacity autoscale max. As per Premium metric app, we seem to have around 60 users connected to the capacity and just two users accessing the dataset for this specific report.

 

And similarly, our paginated reports are looping as well. It says "Loading Report" and then finally fails with this screen -

prathyoo_0-1631785740046.png

 

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors
Top Kudoed Authors