Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
LukasR
Frequent Visitor

PowerBi Service changes Decimal- and Thousand- Separator

Hello everyone,

 

again another Decimal- and Thousand- Separator issue.

 

I have created a paginated report with report builder. In report builder I have created a table and Thousand-separator (dot) and decimal separator (comma) are shown as I wish. Once I publish the report to the Service, it changes dot to comma and vice versa.

I understand this has something to do with the regional settings. I have checked all the settings on my computer as well as my microsoft account and it's all set to 'German'. What do I have to do to get the right settings?

 

It also backwards the time by one hour when I publish.

 

Thanks for your help!

Lukas

1 ACCEPTED SOLUTION

I finally worked it out myself.

In the local settings menu in report builder I manually set every numbers Language to German.

LukasR_0-1646031449561.png

 

Cheers,

Lukas

View solution in original post

11 REPLIES 11
v-chenwuz-msft
Community Support
Community Support

Hi @LukasR ,

 

You can probably refer to the similar solved post for reference:

http://schoennie.blogspot.com/2018/11/thousand-separator-and-decimal.html 

 

Best Regards

Community Support Team _ chenwu zhu

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

The problem is rely clear however if you set the regional settings for your country language (for me Dutch) then other reports that are still being made in Excel are being affected due to this. Because reporting names like for days are being converted in to the language (dutvh) which I have then in my settings while I actualle need to have in English. So in my opinion Power Bi has a flaw

Hello chenwu zhu,

unfortunately this doesn't help, either. I've got my system set to German. And when I modify the report in the report builder desktop app it shows the separators correct. Only when I upload to the service it changes them. Ironically it shows the separators in a power bi dataset correctly as well. Only the report is the other way around.

I've a premium workspace for the report and a pro workspace for the report. Are there different settings for the different workspaces?

Hi @LukasR ,

 

Which language did you choose for Power BI Service? It determines the format of your reports. Please refer to the snapshot below and try to change it.

vchenwuzmsft_0-1644980061924.png

Best Regards

Community Support Team _ chenwu zhu

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Same here, the settings are all set to german already. The awkward thing is, my pro workspace is working fine. Only the with report builder made report in my premium workspace is mixing it up.

Hi @LukasR ,

 

I'm sorry it didn't solve your problem, Please consider creating a support ticket in Power BI Support if you are a Pro user. Then, there will be a support engineer help you troubleshoot on this issue. It couldn’t be better if you post the root cause and the solution here to help other users who may encounter similar issue after you get them from the support engineer. Thanks in advance!

 

For how to create a support ticket, please refer to this blog.

The link of Support: Support | Microsoft Power BI

 

Best Regards

Community Support Team _ chenwu zhu

 

 

Greg_Deckler
Super User
Super User

@LukasR Hmm, looks like the tenant is UTC +1 which is Central European Time so not sure why it would go back an hour unless your local machine is set to UTC +2 which is, I believe, Central European Summer Time.


@ me in replies or I'll lose your thread!!!
Instead of a Kudo, please vote for this idea
Become an expert!: Enterprise DNA
External Tools: MSHGQM
YouTube Channel!: Microsoft Hates Greg
Latest book!:
The Definitive Guide to Power Query (M)

DAX is easy, CALCULATE makes DAX hard...
Greg_Deckler
Super User
Super User

@LukasR The time issue is likely where your tenant is located. In the Service, use the ? icon in the upper right and go to About to see where your tenant is provisioned.


@ me in replies or I'll lose your thread!!!
Instead of a Kudo, please vote for this idea
Become an expert!: Enterprise DNA
External Tools: MSHGQM
YouTube Channel!: Microsoft Hates Greg
Latest book!:
The Definitive Guide to Power Query (M)

DAX is easy, CALCULATE makes DAX hard...

I finally worked it out myself.

In the local settings menu in report builder I manually set every numbers Language to German.

LukasR_0-1646031449561.png

 

Cheers,

Lukas

Thanks, the first working solution I've been able to find for this clear oversight by Microsoft.

Hey @Greg_Deckler ,

 

thanks for your answer. I've looked it up as you mentioned, but this is in Germany, too.

LukasR_0-1644411416672.png

 

Cheers, Lukas

 

Helpful resources

Announcements
LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors