Forum Discussion
PowerBI Service error: OData: Unable to read data from the transport connection:
Hi Shaishavm,
This issue may be caused by some database modifications and they may bring some performance problems and prevent the report from refreshing data. Hope these official docs help you.
Enabling Power BI Integration With Business Central - Business Central | Microsoft Docs
Performance Article For Developers - Business Central | Microsoft Docs
But for such kind of issue, troubleshoot with the support engineer is necessary for the error is general and it needs further investigation. May I know whether you get any update from the support engineer for now?
If there is any post helps, then please consider Accept it as the solution to help the other members find it more quickly. If I misunderstand your needs or you still have problems on it, please let me know. Thanks a lot!
Best Regards,
Community Support Team _ Caiyun
Hi,
Thanks for your reply.
We have been using oData Web Services and running reports without any issues for last 2 years.
This issue started after our environment was upgraded to version 20.0.
A case is opened with Power BI team, they are taking assistance from Business Central technical support. However, there is no solution for 10 days now.
I wonder whether Business Central and Power BI are as compatible as Microsoft advertises.
Apprecaite any help!
Regards,
SM
- v-cazheng-msft4 years ago
Community Support
Hi Shaishavm,
Thanks for your reply! I got it. May I know whether you receive any update from Business Central support team?
Best Regards,
Community Support Team _ Caiyun
- grantbrimhall4 years agoRegular Visitor
Hi: I work for a Microsoft Partner. This is a pervasive problem. This mysterious "Unable to read data from the transport connection. The connection was forcibly closed by the remote host." It comes and it goes. As the author has indicated, his ODATA connections have worked great for 2 years. Then all the sudden they don't. We had other clients on BC that were great until v20. And then they get this dreaded error. (not all of them, but many). One client's errors went away after upgrading to v20.1. But like this author, we have another client who is still problematic after v20.1.
I've been chasing this error for 12-18 months. It comes and it goes. Seems like the past few weeks we are getting an extraordinary amount of these errors. I don't think it's necessarily a BC v20 issue. But I imagine in a week or so, this error will go away for the most part. Then stay quiet for a couple months. Then lots of customer will complain about it again.
Nobody at BC or PowerBI/Query will take ownership of this. they just point the finger at each other. I'm trying to get Fiddler logs to help ascertain the problem. But by the time I get them setup, I can't recreate the error again. I'm going to try again now.
- v-cazheng-msft4 years ago
Community Support
Thanks for the info! I got it. Please observe the work of the v20.1 Connector in the future days. If you find this issue happen again, then please reach to the support with your logs for further investigation. Thanks in advance!
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly. If I misunderstand your needs or you still have problems on it, please feel free to let me know. Thanks a lot!
Best Regards,
Community Support Team _ Caiyun
- BjornSouv4 years agoRegular Visitor
Hi,
I'm having the exact same problem at one of our customers after we upgraded to BCv20.
So any news on this is welcome.
I'll also log a support case for this issue.- grantbrimhall4 years agoRegular Visitor
We don't have any clients complaining right now. But I'm sure they will return. and they will return in bunches. No one at Microsoft can give us any indication when/why it happens.