Forum Discussion

David_Evans's avatar
David_Evans
Frequent Visitor
1 year ago

PowerBI Connection via a Gateway Offline

Hi,

Since Friday evening 18/10/2024, our connection to a server via our gateway has been 'Offline', the message I get when trying to connect is :

'Unable to update connection credentials. Logging into Sql server failed. Possible reasons for this error include an invalid authentication mode, a missing login in Sql server, a login from an untrusted domain or a problem contacting the domain controller for the authentication request.'

I've:

- Updated the gateway to the latest version.

- Restarted the gateway

- Tried different credentials

- Tried creating a new connection in the gateway

 

The gateway server can be pinged from a desktop and the server with the database on can be pinged from the gateway.

Any ideas what to try next?

Regards

David

 

3 Replies

  • Read the latest Gateway Version blog.  Trusted Server settings.

    • david_busint's avatar
      david_busint
      Icon for Advocate I rankAdvocate I

      Thank you. That looks to be the issue. Will give the proposed solution a go. 

  • Anonymous's avatar
    Anonymous
    Not applicable

    Your solution is so great lbendlin

    Hi, David_Evans 

    The current error is that it is now the default behavior for all PBI desktop and gateway versions that are equal to or higher than the February 2024 release.

    Solved: Assistance Required with SQL Server Standard Mode ... - Microsoft Fabric Community

     

     

     

    Best Regards

    Jianpeng Li

    If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.