Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
vhello
Frequent Visitor

Power BI real-time dashboard tiles - Historic Data

I've been trying out the new Real Time dashboard tiles with Streaming Dataset

In my personal space I can see that 1 mb is used in each of my streaming dataset.

However I'm noticing my new telemetry is not being saved in the Historic Data.

 

From my Streaming Dataset, I selected "Create Report" action.

This will take me to the report page with the data. However by looking at the data I've been missing weeks of testing data.

I've pushed some data today and I can see the visuals update on in the dashboard.

But my report data from historic data is still not up to date. It's showing data up to 8/23.

 

Any ideas?

Thanks

-Helen

1 ACCEPTED SOLUTION
vhello
Frequent Visitor

After support I've found the issue:

 

Looks like I pushed extra column data that is not specified in the Power BI Streaming Data.

eg.,

[{"device_type":"thermoMeter","DataTimestamp":"9/12/2016 5:14:42 PM","mac_address":"Thermal_Simulator","Temperature":200,"Humidity":446}]

"device_type" isn't on my Streaming Data table since I didn't need it in the Power BI side.

This will give an error when Power BI inserts the row.

Either add the column to the table or remove device_type value to fix this.

 

Thanks for great support 🙂

 

-Helen

View solution in original post

3 REPLIES 3
sirui_sun
Employee
Employee

Hello - 

 

Happy to help. First, let me make sure I understand the problem. Can you confirm that the following is true:

 

  • A while back, you created a streaming dataset via API option, and enabled historic analysis
  • You've been sending data to this streaming dataset over the past few weeks
  • Today, when you push data, the visuals on your dashboard do update
  • However, when you go to build a report, you don't see any data since 8/23

 

- A while back, you created a streaming dataset via API option, and enabled historic analysis

  Yes
- You've been sending data to this streaming dataset over the past few weeks

  I've been sending data on and off but not continuously
- Today, when you push data, the visuals on your dashboard do update

  Yes
- However, when you go to build a report, you don't see any data since 8/23

  Yes

vhello
Frequent Visitor

After support I've found the issue:

 

Looks like I pushed extra column data that is not specified in the Power BI Streaming Data.

eg.,

[{"device_type":"thermoMeter","DataTimestamp":"9/12/2016 5:14:42 PM","mac_address":"Thermal_Simulator","Temperature":200,"Humidity":446}]

"device_type" isn't on my Streaming Data table since I didn't need it in the Power BI side.

This will give an error when Power BI inserts the row.

Either add the column to the table or remove device_type value to fix this.

 

Thanks for great support 🙂

 

-Helen

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Power BI Header Change

Power BI Header Update

Read about the exciting updates for the Power BI forum.

Top Solution Authors
Top Kudoed Authors